FIX: Critical startup events are not logged in the .NET Framework 1.1 Service Pack 1 (890666)



The information in this article applies to:

  • Microsoft .NET Framework 1.1 Service Pack 1 (SP1)

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

Critical startup events are not logged in the Microsoft .NET Framework 1.1 Service Pack 1.

CAUSE

The .NET Framework 1.1 Service Pack 1 does not use any kind of logging facility to capture critical startup events. Therefore, you may experience problems when you try to troubleshoot critical startup problems.

RESOLUTION

Software update information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next .NET Framework 1.1 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

The .NET Framework 1.1 Service Pack 1

Restart requirement

You must restart your computer after you apply this software update.

Software update replacement information

This does not replace any other hotfixes.

File information

The English version of this software update has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version         Size      File name
----------------------------------------------------------
17-Nov-2004  05:57  1.1.4322.2048  2,138,112  Mscorlib.dll 
16-Nov-2004  02:28  1.1.4322.2048  2,514,944  Mscorsvr.dll 
16-Nov-2004  02:29  1.1.4322.2048  2,506,752  Mscorwks.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To use the logging facility in this hotfix, follow these steps:
  1. Add the StressLog REG_DWORD: Disabled 0 (Default) Enabled value to the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.Net Framework subkey. To do this, follow these steps:
    1. Click Start, click Run, type regedit, and then click OK.
    2. In the Registry Editor window, expand HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft in the left pane.
    3. Right-click .NetFramework, point to New, and then click DWORD Value.
    4. Name the new DWORD value "StressLog."
    5. Right-click StressLog in the right pane, and then click Modify.
    6. In the Edit DWORD Value dialog box, type 1 in the Value data box, and then click OK.
  2. Start the process that you want to troubleshoot in the Windbg debugger.
  3. When startup fails or when a problem occurs, you can put the log information in the Windbg debugger. You can do this by using the Sos.dll file. You can issue the following commands to use the Sos.dll file in the Windbg debugger:
    1. Type the following command at the command line to load the Sos.dll file in the Windbg debugger:

      .load sos.dll
    2. Type the following command to load the dump file:

      !DumpLog [<filename>]

      Note By default, if you do not specify a file name, StressLog.txt is loaded.

REFERENCES

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/7/2005
Keywords:kbBug kbfix kbQFE KB890666 kbAudDeveloper kbAudITPRO