"TOO_MANY_OPEN_FILES" error message when the redirector component in Windows Server 2003 uses the SMB protocol to open a file in a shared network folder (890584)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When the redirector component in Microsoft Windows Server 2003 uses the Server Message Block (SMB) protocol to open a file that is located in a shared network folder, you may receive the following error message:
The system cannot open the file.
When you use Network Monitor to trace the network traffic, you may receive the following error message:
TOO_MANY_OPEN_FILES
Additionally, when you use the Open Handles (OH) monitoring tool (Oh.exe) to view the open handles of the client process, no open handles are reported.

Note The OH monitoring tool shows the handles of all open windows. Alternatively, you can limit the OH display to show only information relating to a particular process, object type, or object name. This feature is useful when a sharing violation occurs because you can find the process that has a file open at the time of violation.

However, when you run the Net Files command at a command prompt on the Windows Server 2003-based computer to view the handles that are opened by clients, there may be hundreds or even thousands of files open.

CAUSE

This problem occurs when the files in the dormant file cache are not closed correctly.

By default, the redirector component in Windows Server 2003 does not immediately close files on the server for performance reasons. However, the closed files are cached in this scenario. This problem may occur on the Windows Server 2003-based computer even though no error message is displayed.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows Server 2003, 64-bit editions
   Date         Time   Version            Size    File name
   ---------------------------------------------------------
   24-Nov-2004  01:39  5.2.3790.235    1,124,864  Mrxsmb.sys
   24-Nov-2004  01:39  5.2.3790.235      465,408  Rdbss.sys
Windows Server 2003, 32-bit editions
   Date         Time   Version            Size    File name
   ---------------------------------------------------------
   24-Nov-2004  01:34  5.2.3790.235      395,776  Mrxsmb.sys
   24-Nov-2004  01:34  5.2.3790.235      158,720  Rdbss.sys

MORE INFORMATION

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk. By default, the number of closed files that can be cached is 45. This setting is controlled by the DormantFileLimit registry value. This registry value is located under the following subkey:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet \Services\LanmanWorkstation\Parameters

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbWinServ2003preSP1fix KB890584 kbAudITPRO