You receive a "STOP 0x000000D1" error message on a blue screen in Windows Server 2003 (890554)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems

SYMPTOMS

You experience the following symptoms on your Microsoft Windows Server 2003-based computer:
  • You receive a Stop error message on a blue screen. The error message is similar to the following:
    STOP 0x000000D1, (0xf2bc8c92, 0x00000002, 0x00000000, 0xf2bc8c92) IRQL_NOT_LESS_OR_EQUAL
  • The computer unexpectedly restarts.
These symptoms occur when the computer is under a heavy load. For example, you may experience these symptoms when you copy large files from a remote share when the server is under a heavy load.

CAUSE

This problem occurs when a browser announcement frame is incorrectly processed by the server message block (SMB) redirector. The SMB redirector tries to run code that is paged out and that cannot be paged in at the current interrupt request (IRQ) level.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows Server 2003, 32-bit versions

Date         Time   Version         Size     File name
-------------------------------------------------------
06-Dec-2004  22:08  5.2.3790.240   395,776   Mrxsmb.sys
06-Dec-2004  22:08  5.2.3790.240   158,720   Rdbss.sys

Windows Server 2003, 64-bit versions

Date         Time   Version          Size    File name
-------------------------------------------------------
01-Dec-2004  03:07  5.2.3790.238  1,124,864  Mrxsmb.sys
01-Dec-2004  03:07  5.2.3790.238    465,408  Rdbss.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about the terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbWinServ2003preSP1fix KB890554 kbAudITPRO