USB devices stop working in Windows XP Media Center Edition (890546)
The information in this article applies to:
- Microsoft Windows XP Media Center Edition 2005
- Microsoft Windows XP Media Center Edition 2004
- Microsoft Windows XP Media Center Edition
SYMPTOMS
You may experience one or more of the following symptoms on your Microsoft Windows XP Media Center Edition-based computer:
- The remote device stops working while you are changing TV channels.
- An external universal serial bus (USB) hard disk stops working.
- Other USB peripheral devices, such as card readers, keyboards, or mouse devices stop working.
These devices are typically connected to an internal USB hub.
Note When these devices are connected to an internal USB hub, the connections are not visible. Therefore, you may not be able to see that the devices are connected to the computer's USB bus.
CAUSE
These problems may occur with certain hardware configurations when you perform certain actions. These actions include the following:
- You disconnect a storage device, such as an external USB hard disk, before you stop the device.
- You continuously or frequently change TV channels by using the remote.
These problems occur because of an error in the USB bus. If the Irbus.sys driver cannot recover from this error, any devices that use the USB bus will stop working. RESOLUTIONA supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix. To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date Time Version Size File name
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08-Dec-2004 00:13 5.1.2600.2578 17,024 Hidir.sys
08-Dec-2004 00:13 5.1.2600.2578 46,208 Irbus.sys
WORKAROUND
To work around these problems, use one of the following methods:
- Disconnect and then reconnect the device that is not working.
- Log off and then log back on to the computer.
- Restart the computer.
- Before you disconnect a storage device such as an external hard disk, first stop the device. Or, use the Safely Remove Hardware feature to notify the operating system that you are about to unplug the device.
To do this, follow these steps:
- Click the Safely Remove Hardware icon in the notification area. This icon displays a notification bubble with a list of devices that currently are attached to the system.
- Click the device that you want to remove. This stops the device, and then you can safely unplug it.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
Modification Type: | Minor | Last Reviewed: | 6/2/2006 |
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Keywords: | kbWinXPsp3fix kbWinXPpreSP3fix kbfix kbbug kbQFE kbHotfixServer KB890546 kbAudEndUser |
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