A "<virtual_machine_name> could not be started because access was denied to one of the virtual hard disks" entry is logged in the Virtual Server log when the computer restarts (890324)



The information in this article applies to:

  • Microsoft Virtual Server 2005 Enterprise Edition English (United States)
  • Microsoft Virtual Server 2005 Standard Edition English (United States)

SYMPTOMS

Consider the following scenario:
  • You encrypt a virtual hard disk (.vhd) file in Microsoft Virtual Server 2005 by using a user account.
  • You set the virtual machine to automatically turn on when the computer restarts.
In this scenario, the following entry may be logged in the Virtual Server log when the computer restarts:
virtual_machine_name could not be started because access was denied to one of the virtual hard disks.
Note This problem occurs when you configure the virtual machine to run under the user account that encrypted the virtual hard disk.

CAUSE

This problem occurs because the user account environment is not loaded when Virtual Server 2005 tries to turn on the virtual machine by using the encrypted virtual hard disk. Therefore, Virtual Server 2005 cannot access the encrypted virtual hard disk.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Virtual Server 2005 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, you must restart the Virtual Server service. To do this, you must first stop all virtual machines.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version           Size  File name
   --------------------------------------------------------------------
   23-May-2005  07:54                 558,034  Docscomh
   23-May-2005  07:54                   7,974  Docscomlib
   23-May-2005  07:54  1.1.465.13      72,432  En_usmsgdll
   23-May-2005  07:54  1.1.465.13     199,416  Interopasm
   23-May-2005  07:54  1.1.465.13      72,432  Virtualserverlogmessages
   23-May-2005  07:54              26,947,584  Vmadditions
   23-May-2005  07:54  1.1.465.13     154,368  Vmh.dll          
   23-May-2005  07:54  1.1.465.13     151,768  Vmmsys.dll       
   23-May-2005  07:54  1.1.465.13     363,256  Vmrcclientapp
   23-May-2005  07:54  1.1.465.13   2,980,576  Vssrvc
   23-May-2005  07:54  1.1.465.13   1,669,872  Vswebapp
   23-May-2005  07:54                 225,257  Vswebappactivexcab

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the terminology that Microsoft uses when it corrects software after the software has been released, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:5/15/2006
Keywords:kbVirtualSrv05preSP1fix kbBug kbfix kbprb kbQFE kbHotfixServer KB890324 kbAudITPRO