A sender does not receive a status code 302 response after a message is sent to an RTC 1.3 Client program in Live Communications Server 2005 (890305)



The information in this article applies to:

  • Microsoft Office Live Communications Server 2005 Enterprise Edition
  • Microsoft Office Live Communications Server 2005 Standard Edition

SYMPTOMS

After you create a program that uses the Microsoft Real-time Communications (RTC) Client version 1.3 API, you may experience the following symptoms.

Consider the following scenario:
  • You create a program that uses the RTC Client version 1.3 API.
  • The program is configured with multiple end points or devices.
  • The program is configured to forward calls from one end point to another location.
  • Another user sends an INVITE request to this program's user.
In this scenario, the sender's program does not receive a status code 302 response, a session forward-request response. Instead, after two minutes, the INVITE request times out.

CAUSE

This issue occurs because the calls remain in an "InProgress" state with the remaining end points if the following conditions are true:
  • Your program is configured with multiple end points.
  • One of those end points is configured to forward calls to another location.
These calls remain in an "InProgress" state for up to one hour. After one hour, the sender times out. In this scenario, the server does not send the 302 response to the sender.

RESOLUTION

To resolve this issue, configure the other end-points to reject the call. In this scenario, you must configure your program to determine whether to forward the calls or whether to fork the calls to multiple end points.

MORE INFORMATION

For additional information about the RTC Client, visit the following Microsoft Web site:For additional information about how to obtain the RTC Client API, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:12/1/2004
Keywords:kbtshoot kbprb KB890305 kbAudDeveloper