Your USB devices may stop working when you transfer data between a USB 2.0 storage device and your Windows 2000-based computer (890202)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Advanced Server

For a Microsoft Windows Server 2003 version of this article, see 873402.

SYMPTOMS

When you transfer more than 64 kilobytes (KB) of data between a USB 2.0 storage device and your Microsoft Windows 2000-based computer, all or some of your USB devices may stop working.

CAUSE

This problem may occur if you start the computer with the Physical Address Extension (/PAE) switch turned on. Typically, this switch is found in the Boot.ini file.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To install this hotfix, you must have Windows 2000 Service Pack 3 (SP3) installed on your computer.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size    File name
   ------------------------------------------------------
   10-Dec-2004  08:03  5.0.2195.7009  23,536  Usbstor.sys

WORKAROUND

To work around this problem, remove the /PAE switch from the Boot.ini file. To do this, follow these steps:
  1. Start Windows Explorer.
  2. On the Tools menu, click Folder Options.
  3. On the View tab, click Show hidden files and folders, click to clear the Hide protected operating system files check box, and then click OK.

    If a warning dialog box appears, click Yes to continue.
  4. Locate the Boot.ini file and remove its read-only attribute.

    The Boot.ini file is in the root folder of the hard disk drive where Windows is installed.
  5. Open the Boot.ini file in Notepad, and then remove the /PAE switch.

    The /PAE switch is located in a line that is similar to the following:
    multi(0)disk(0)rdisk(1)partition(2)\WINnt="Windows server" /PAE
  6. On the File menu, click Save, and then quit Notepad.
  7. Reset the read-only attribute of the Boot.ini file.
  8. Restart your computer.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about the new file naming schema for Microsoft Windows software update packages, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

For additional information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/2/2006
Keywords:kbBug kbfix kbWin2000preSP5fix kbQFE kbHotfixServer KB890202 kbAudEndUser