URL that contains DBCS characters may be corrupted in an e-mail in OWA (890059)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition

SYMPTOMS

When an e-mail message includes a URL that contains Traditional Chinese, Simplified Chinese, Japanese, or Korean characters (also known as double-byte character set (DBCS) characters), Outlook Web Access (OWA) users may not be able to access the URL when they click it in the body of the message.

CAUSE

This problem may occur when the DBCS characters in the URL are not converted to UTF-8 characters when OWA retrieves the HTML message from the Information Store. In this scenario, the URL is corrupted.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Exchange Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Because of file dependancies, this hotfix requires Microsoft Exchange Server 2003 Service Pack 1.

Restart requirement

The Microsoft Exchange Information Store service automatically stops and then starts again when you install this hotfix.

Hotfix replacement information

This hotfix does not replace any other software updates.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size       File name
   -----------------------------------------------------------
   14-Jan-2005  02:07  6.5.7232.69       295,936  Isinteg.exe      
   14-Jan-2005  02:19  6.5.7232.69     3,261,952  Mdbmsg.dll       
   14-Jan-2005  02:53  6.5.7232.69     5,166,592  Store.exe  

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Exchange Server 2003 Service Pack 2.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

817903 New naming schema for Exchange Server software update packages


Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbExchange2003preSP2fix kbfix kbBug KB890059 kbAudITPRO