You receive an "Invalid log version" error message when you use the ESEUTIL /K command on a folder where transaction logs reside in Exchange Server 2003 SP1 (890056)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Standard Edition, Service Pack 1 (SP1)
  • Microsoft Exchange Server 2003 Enterprise Edition, Service Pack 1 (SP-1)
  • Microsoft Windows Small Business Server 2003, Standard Edition
  • Microsoft Windows Small Business Server 2003, Premium Edition

SYMPTOMS

When you use the eseutil /k log file command on a folder where transaction logs reside in Microsoft Exchange Server 2003 Service Pack 1 (SP1), you receive the following error message:
ERROR: Invalid log version. Format LGVersion: (7.3704.8). Expected: (7.3704.5).
For example, if you run the command on the Exchsrvr\Bin folder, you receive this error message. Additionally, the eseutil command stops, and you receive the following error message:
Operation terminated with error -514 (JET_errBadLogVersion, Version of log file is not compatible with Jet version) after nn:nn seconds.

CAUSE

This problem occurs if you use the eseutil command on log files that were created before you upgraded to Exchange Server 2003 SP1.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Because of file dependencies, this hotfix requires Exchange Server 2003 SP1. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart your computer after you install this hotfix. However, you must restart the following services after you install this hotfix:
  • Microsoft Exchange MTA Stacks
  • Microsoft Exchange Information Store
  • Microsoft Exchange System Attendant

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time   Version         Size       File name
--------------------------------------------------------------
28-Dec-2004  02:50  6.5.7232.63     2,115,072  Ese.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about the eseutil /k command, click the following article numbers to view the articles in the Microsoft Knowledge Base:

823167 How to use the Eseutil utility to perform a checksum procedure on a streaming file

825088 How to use the Eseutil utility to detect file header damage in Exchange 2003

867626 New error correcting code is included in Exchange Server 2003 Service Pack 1

For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

817903 New naming schema for Exchange Server software update packages


Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbexchSTORE kbfix kbBug kbExchange2003preSP2fix KB890056 kbAudITPRO