Changing Computer's Role Causes Workstation to Not Start (89436)






This article was previously published under Q89436

SYMPTOMS

If you change a server's role from backup or primary to standalone and back again (as when you synchronize the user accounts database) services such as the Remote Access Service (RAS) no longer start.

CAUSE

When a server's role is changed to standalone, the Netlogon Service is removed. (You can confirm this by looking at the srvservices line in the LANMAN.INI file.) When the role is changed to backup or primary, the Netlogon service is added, but it is added to the end of the srvservices line in the LANMAN.INI file, so all services before Netlogon are started first. Some services such as the Remote Access Service require Netlogon to be running before they can start, so they fail to start, preventing the workstation from starting.

RESOLUTION

After switching roles on a server (for example, backup -> standalone -> backup), examine the LANMAN.INI file and make sure that the Netlogon service is listed before any other service, such as RAS.

Modification Type: Major Last Reviewed: 7/30/2001
Keywords: KB89436