Some files are lost after you perform an RIS volume restore in Windows Server 2003 (889714)



The information in this article applies to:

  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Small Business Server 2003, Premium Edition
  • Microsoft Windows Small Business Server 2003, Standard Edition

SYMPTOMS

Some files are not restored after you backup and then restore a Remote Installation Services (RIS) volume in Microsoft Windows Server 2003. When you verify the contents of the backup media, you find that the files that are not restored cannot be located on the backup media.

CAUSE

This problem occurs when the following conditions are true:
  • The volume that contains the RIS files that you backed up is managed by the Single Instance Store (SIS) service.
  • SIS replaces multiple copies of files on the volume with pointers to a single instance of each file in the SIS Common Store directory.
  • The backup set that you created cannot access the SIS Common Store.

WORKAROUND

To work around this issue, you must back up your RIS volume from a share drive. This share drive must point to the root of the RIS volume that contains the common-store directory.

MORE INFORMATION

RIS servers use SIS to reduce disk usage by combining multiple copies of the same file into a common store. The RIS servers then link to that common file instead of duplicating the actual bits on disk. Backup of this data is accomplished by identifying the link files and adding the common store file to the backup set.

The SIS Common Store can be backed up, but you are not required to do this. When backup sets have access to the SIS Common Store, the backup media will contain the common-store files that are required when you restore the RIS volume.

If you want to restore an RIS volume to a new RIS server, make sure that you install RIS before you perform the restore. This will make sure that SIS is installed and is attached to the volume.

To restore an RIS volume to the same RIS server that was backed up, you must follow these steps before you perform the restore:
  1. Make sure that the drive is online and is formatted with the NTFS file system. To do this, follow these steps:
    1. Click Start, right-click My Computer, and then click Manage.
    2. In the Computer Management console, click Disk Management.
    3. In the details pane, verify that the RIS volume is online and is formatted with NTFS.
  2. Run the RIS Setup program (Risetup.exe), and examine the remote installation server for errors. To do this, follow these steps:
    1. Click Start, click Run, type risetup in the Open box, and then click OK.
    2. On the Remote Installation Services Setup Wizard, click Next, click to select the Check this remote installation server for errors option, click Next, and then click Finish.

      Note If the Check this remote installation server for errors option does not appear, then RIS is not installed on this computer.

  3. Verify that the SIS service is started. To do this, follow these steps:
    1. Click Start, point to Administrative Tools, and then click Services.
    2. In the list of services, locate the Single Instance Storage Groveler service, and make sure that it is started.
Note All editions of Windows Server 2003, except for the Web Edition, include RIS. RIS is also included with Microsoft Windows 2000.

Important If your network uses RIS with Windows 2000 Server, you should upgrade the RIS server to Windows Server 2003 before you upgrade any other computer. Otherwise, you will not be able to use RIS after the upgrade. This behavior occurs because of design changes in the way that Active Directory directory service performs authentication. When you upgrade the RIS server to Windows Server 2003, the RIS server can then communicate with the remaining Windows 2000 domain controllers, and also with Windows Server 2003 domain controllers.

Note that for administrators, the Start menu in Windows Server 2003 is different from the Start menu in Windows 2000 Server.

For additional information about how to deploy new operating systems, visit the following Microsoft Web site: http://www.microsoft.com/technet/prodtechnol/windows2000serv/deploy/depopt/remoteos.mspx

Modification Type:MinorLast Reviewed:12/9/2005
Keywords:kbwinservperf kbMgmtServices kbService kbDisasterRec kbBackup kbtshoot kbprb KB889714 kbAudITPRO kbAudOEM