Web log analysis shows an inaccurate number of visits in Commerce Server 2002 (889579)



The information in this article applies to:

  • Microsoft Commerce Server 2002

SYMPTOMS

Web log analysis shows an inaccurate number of visits in Microsoft Commerce Server 2002. Specifically, when you view the Visit number in the Commerce Server 2002 Web log analysis report, you determine that this number is not accurate.

If you use other Web site analysis products, you notice that the average number of hits per Web site visit is very different from the number that is reported in the Commerce Server 2002 Web log analysis report.

CAUSE

This issue occurs because Commerce Server 2002 infers the number of individual visits to a Web site by using the referring domain that the user visits a site from and by using a time-out value for each visit. This time-out value can be configured, but the default time-out value is 30 minutes. Other Web site analysis products use only a 30-minute time-out to calculate Web site visits.

RESOLUTION

To resolve this issue, set the UseExternalReferrerForInference environment variable to False. This change configures Commerce Server 2002 to use only a 30-minute timeout value to calculate visits to your Web site. To do this, follow these steps:
  1. Right-click My Computer, and then click Properties.
  2. Click the Advanced tab, and then click Environment Variables.
  3. Under System variables, click New.
  4. In the Variable Name box, type UseExternalReferrerForInference.
  5. In the Variable Value box, type F.
  6. Click OK three times.

MORE INFORMATION

For additional support information for Commerce Server 2002, visit the following Microsoft Web site: For additional information about how to obtain Commerce Server 2002 Feature Pack 1, visit the following Microsoft Web site:

Modification Type:MajorLast Reviewed:1/28/2005
Keywords:kbprb KB889579 kbAudDeveloper