FIX: A TN3270 client can connect to a TN3270 LU after an administrator removes the TN3270 client workstation name from the TN3270 LU configuration in Host Integration Server (889522)



The information in this article applies to:

  • Microsoft Host Integration Server 2000
  • Microsoft Host Integration Server 2000 SP1
  • Microsoft Host Integration Server 2000 SP2
  • Microsoft Host Integration Server 2004

SYMPTOMS

After a Microsoft Host Integration Server administrator removes a TN3270 client workstation name from a TN3270 logical unit (LU) configuration, the TN3270 client can connect to the TN3270 LU.

If the TN3270 service is stopped and then restarted, the TN3270 client can no longer connect to the TN3270 LU.

CAUSE

SNA Manager does not inform the TN3270 service when a workstation name is removed from a TN3270 LU configuration. Therefore, the change does not take effect until the TN3270 service is stopped and then restarted.

RESOLUTION

Microsoft Host Integration Server 2000

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Host Integration Server 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size     File name
   -----------------------------------------------------
   22-Apr-2005  01:22  5.0.0.2061  340,240  Snaadmin.dll
Note Because of file dependencies, the most recent hotfix that contains this file may also contain additional files.

Microsoft Host Integration Server 2004

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Host Integration Server 2004 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size     File name
   -----------------------------------------------------
   22-Jan-2005  00:18  6.0.1930.0  302,592  Snaadmin.dll
Note Because of file dependencies, the most recent hotfix that contains this file may also contain additional files.

WORKAROUND

After you remove a workstation name from any TN3270 LU, stop and then restart the TN3270 service to enable the change.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:7/25/2006
Keywords:kbHotfixServer kbQFE kbfix kbbug kbpubtypekc KB889522 kbAudDeveloper