You receive a "Missing or Invalid Product Key." error message after you upgrade to Virtual PC 2004 Service Pack 1 (889508)



The information in this article applies to:

  • Microsoft Virtual PC 2004 Service Pack 1

SYMPTOMS

After you install and start Microsoft Virtual PC 2004 Service Pack 1 (SP1), you receive the following error message:

Missing or Invalid Product Key.

CAUSE

This problem occurs if you perform a quiet (unattended) installation of Virtual PC 2004 SP1 by using the following command line: msiexec.exe /i "Drive_letter:\Path\Microsoft Virtual PC 2004.msi" /qn.

A typical installation of Virtual PC 2004 SP1 uses the Setup Wizard. A typical installation saves the product key for Virtual PC 2004 for use with Virtual PC 2004 SP1. When you perform a quiet installation, the product key is not saved correctly. Therefore, the error occurs.

WORKAROUND

To work around this problem, you can perform a quiet installation of Virtual PC 2004 SP1 by using the PIDKEY Setup switch, as in the following example:
msiexec.exe /i "Drive_letter:\Path\Microsoft Virtual PC 2004.msi" /qn PIDKEY=XXXXXXXXXXXXXXXXXXXXXXXXX, where the string of "X" characters is your 25-character Product Identification number for Virtual PC 2004 SP1.

Modification Type:MajorLast Reviewed:12/21/2004
Keywords:kbsetup kbtshoot kbprb KB889508 kbAudEndUser kbAudITPRO