You cannot use Remote.exe to connect to a Systems Management Server 2.0 client computer after running the Conv20.exe utility (889434)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0

SYMPTOMS

After you run the Conv20.exe utility on a Microsoft Systems Management Server (SMS) 2.0 site server to test the integrity of the SMS database, when you try to use Remote.exe from the command line to connect to an SMS client, you may receive the following error message:
Access Denied
Additionally, the Smsprov.log file in the /SMS/Logs folder on the SMS site server may contain the following error message:
Error Extracting property:TopLevelSiteCode SQL Error: Could not find stored procedure 'sp_GetRights'

CAUSE

This problem typically occurs after you run the Conv20.exe utility on an SMS site server. The Conv20.exe utility may remove the sp_GetRights stored procedure from the SMS database.

RESOLUTION

To resolve this problem, use Remote Tools in the SMS Administrator console to connect to the SMS client. To do this, follow these steps:
  1. Click Start, point to Programs, point to Systems Management Server, and then click SMS Administrator Console.
  2. In the SMS Administrator console, expand Site Database (SiteCode-SiteName), expand Collections, and then click All Systems.
  3. In the details pane, right-click the SMS client computer, click All Tasks, and then click Start Remote Tools.

    This re-creates the sp_GetRights stored procedure.

    Note The sp_GetRights stored procedure is not re-created when you try to run Remote.exe from the command line.
You can now use Remote.exe from the command line to connect to the SMS client.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

REFERENCES

For additional information about the Conv20.exe tool, click the following article number to view the article in the Microsoft Knowledge Base:

200653 SMS: Using Conv20.exe to check database integrity


Modification Type:MinorLast Reviewed:6/13/2005
Keywords:kbtshoot kbprb KB889434 kbAudITPRO