You may receive an "access denied" error message when a Web site redirects you to another Web page on a computer that is running Windows XP Service Pack 2 (889386)



The information in this article applies to:

  • Microsoft Windows XP Professional Service Pack 2 (SP2)
  • Microsoft Windows XP Tablet PC Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Media Center Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Home Edition Service Pack 2 (SP2)

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you browse a Web site by using Microsoft Internet Explorer on a computer that is running Microsoft Windows XP Service Pack 2 (SP2), you may receive an "access denied" error message. The error message may occur when a Web site redirects you to a Web page that contains script that accesses the document.all collection.

CAUSE

This problem may occur because, when the script code accesses the document.all collection after a client-side script redirect, the context of the earlier document.all collection is lost.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size       File name
   ---------------------------------------------------------
   07-Dec-2004  20:21  6.00.2900.2577  3,006,976  Mshtml.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

You receive this error message only if the computer is running Windows XP SP2. After you apply this hotfix, restart the computer, and then follow these steps.

Note This hotfix is included in the MS05-038 Internet Explorer cumulative update. The following steps to set the registry key value are not required to enable this hotfix when MS05-038 is installed on the computer.
  1. Exit Internet Explorer.
  2. Click Start, click Run, type regedit in the Open box, and then click OK.
  3. Locate and then click the following registry key:

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main

  4. Create a new key that is named FeatureControl under the key that is listed in step 3.
  5. Create a new key that is named FEATURE_REDIRECT_COLLECTIONCACHE_KB889386 under the key that is listed in step 4.
  6. Select the FEATURE_REDIRECT_COLLECTIONCACHE_KB889386 key.
  7. On the Edit menu, point to New, and then click DWORD value.
  8. Type iexplore.exe, and then press ENTER.
  9. Right-click iexplore.exe, and then click Modify.
  10. In the Value data box, type 00000001, and then click OK.
  11. On the File menu, click Exit.

REFERENCES

For more information about Internet Explorer object caching, visit the following Microsoft Web site:

Modification Type:MajorLast Reviewed:5/15/2006
Keywords:kbInetDev kbQFE kbfix kbBug kbHotfixServer KB889386 kbAudDeveloper kbAudITPRO kbAudGeneralUser