File upload in Internet Explorer 6 to a Web page may time out or take longer than expected to complete in Windows XP Service Pack 2 (889334)



The information in this article applies to:

  • Microsoft Windows XP Professional Service Pack 2 (SP2)
  • Microsoft Windows XP Home Edition Service Pack 2 (SP2)

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you try to upload a file to a secure Web site in Microsoft Internet Explorer 6, the file upload may time out or may take longer than expected to finish.

CAUSE

This problem may occur when all the following conditions are true:
  • You have installed Microsoft Windows XP Service Pack 2 (SP2).
  • The Web page to which you upload the file uses a Secure Sockets Layer (SSL) connection.
  • The URL to connect to the secure Web site starts with https://.
  • The Web page to which you upload the file is one of the following:
    • An active server page (.asp).
    • A Web page that uses a script to process the uploaded file.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Windows XP SP2 installed to install this hotfix.

For additional information about how to obtain Windows XP Service Pack 2, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Restart requirement

You may have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

Registry information

After you install this hotfix, follow these steps to enable the hotfix.Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Quit Internet Explorer 6.
  2. Click Start, click Run, type regedit, and then click OK.
  3. Locate and then click to select the following registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BUFFERBREAKING_818408

  4. On the Edit menu, point to New, and then click DWORD Value.
  5. Type Iexplore.exe, and then press ENTER.
  6. Right-click Iexplore.exe, and then click Modify.
  7. In the Value data box, type 1, and then click OK.
  8. Select the key that is specified in step 3.
  9. On the Edit menu, point to New, and then click Key.
  10. Type Settings, and then press ENTER.
  11. With the Settings key selected, on the Edit menu, point to New, and then click DWORD Value.
  12. Type BufferBreakingSize, and then press ENTER.
  13. Right-click BufferBreakingSize, and then click Modify.
  14. In the Value data box, type 00a00000, and then click OK.

    Notes
    • The default value for BufferBreakingSize is 8,000 bytes.
    • Using the recommended Value data value of 00a00000 changes BufferBreakingSize to 10 megabytes (MB).
    • Do not exceed a BufferBreakingSize of 30 MB (Value data = 01e00000).
  15. Quit Registry Editor.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size      File name
   --------------------------------------------------------
   16-Dec-2004  18:38  6.0.2900.2577  656,896   Wininet.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

The hotfix that is described in this article is included in Microsoft Security Update MS05-014.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:5/15/2006
Keywords:kbWinXPpreSP3fix kbQFE kbfix kbbug kbHotfixServer KB889334 kbAudEndUser kbAudITPRO