The Exchange System Manager monitoring tools may incorrectly report that SMTP queues have a critical queue length in Exchange Server 2003 (889180)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition

SYMPTOMS

In Microsoft Exchange Server 2003, when you use the Microsoft Exchange System Manager monitoring tools to monitor Simple Mail Transfer Protocol (SMTP) queue growth, you may experience all the following symptoms:
  • The SMTP Queues growth period resource indicates a status of Critical: Queue Growth. Additionally, if you have e-mail notifications configured, you receive an e-mail notification that indicates that the outbound SMTP queues are growing and are in an error condition.
  • If you view the SMTP queues, you notice that no messages are backed up in the outbound SMTP queues.
  • The following event is logged in the Application log on the Exchange computer:Event Type: Error
    Event Source: MSExchangeSA
    Event Category: (2)
    Event ID: 9100
    Date: date
    Time: time
    User: N/A
    Computer: computername
    Description: The MAD Monitoring thread was unable to read the queue information, error '0xc00402be'.Note This event description may indicate "error '0x80004005'" instead of "error '0xc00402be'."
  • The Wbemcore.log file contains information that is similar to the following:
     (<date and time>) : Error 80041002 occured executing queued request
     (<date and time>) : CAsyncReq_GetObjectAsync, Path= Win32_PerfRawData_MSExchangeDSAccess_MSExchangeDSAccessGlobalCounters in namespace root\cimv2\MS_409 using flags 0x0
     (<date and time>) : Core physically unloaded!
     (<date and time>) : Error 1 occured executing queued request
     (<date and time>) : Loading provider(Fri Apr 16 18:56:34 2004) : Error 80041002 occured executing queued request
     (<date and time>) : CAsyncReq_GetObjectAsync, Path= Win32_PerfRawData_MSExchangeActiveSyncNotify_MSExchangeActiveSyncNotifyOmaPush in namespace root\cimv2\MS_409 using flags 0x0
     (<date and time>) : Error 80041002 occured executing queued request
     (<date and time>) : CAsyncReq_GetObjectAsync, Path= Win32_PerfRawData_REORG_RoutingOrganizationObject in namespace root\cimv2\MS_409 using flags 0x0
     (<date and time>) : Error 80041002 occured executing queued request
     (<date and time>) : CAsyncReq_GetObjectAsync, Path= Win32_PerfRawData_RESvc_RoutingService in namespace root\cimv2\MS_409 using flags 0x0
     (<date and time>) : Error 80041002 occured executing queued request
     (<date and time>) : CAsyncReq_GetObjectAsync, Path= Win32_PerfRawData_SDSMTPROUTING_SMTPRouting in namespace root\cimv2\MS_409 using flags 0x0
     (<date and time>) : Core physically unloaded!
     (<date and time>) : Error 1 occured executing queued request
     (<date and time>) : Loading provider(Fri Apr 16 19:31:59 2004) : Core physically unloaded!
     (<date and time>) : FATAL ERROR: Client application provided a mismatched class part!!!!
    Note By default, the Wbemcore.log file is located in the %WINDIR%\System32\Wbem\Logs folder.
Note Although you may experience these symptoms on any one or more of your Exchange computers, you typically experience these symptoms on your bridgehead servers. Additionally, when this problem occurs, you do not receive a warning notification. Instead, you receive only an error status notification.

CAUSE

This problem may occur if a Windows Management Instrumentation (WMI) query fails. When this query fails, WMI incorrectly reports that the SMTP queues are in an error condition.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Exchange Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next P1 that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Because of file dependencies, you must have Exchange Server 2003 Service Pack 1 (SP1) installed before you apply this hotfix. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   06-Feb-2005  04:14  6.5.7232.78     1,605,120  Exwmi.dll      

WORKAROUND

To work around this problem, restart the Windows Management Instrumentation service. To do this, follow these steps:
  1. Click Start, click Run, type services.msc, and then click OK.
  2. In the Services window, right-click Windows Management Instrumentation, and then click Restart.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Exchange Server 2003 Service Pack 2.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

817903 New naming schema for Exchange Server software update packages


Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbfix kbBug KB889180 kbAudITPRO