FIX: You may experience a system freeze when you try to cancel a COM+ method by using the CoCancelCall method while a COM+ object that uses the CoCreateInstanceEx method is instantiated in Windows XP Professional (889178)



The information in this article applies to:

  • Microsoft Windows XP Professional

SYMPTOMS

Consider the following scenario. In Microsoft Windows XP Professional, a Microsoft COM+ object that uses the CoCreateInstanceEX function is instantiated in a COM+ application. When you try to cancel a COM+ method by using the CoCancelCall function, you may experience system freeze-like symptoms.

Note This problem occurs after you restart the server side of the COM+ application.

CAUSE

This problem occurs because a race condition exists between the following:
  • The end call that goes to the server
  • The server that sends the response
Therefore, a fatal error occurs in the DCOM. This fatal error causes the computer to stop responding.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Microsoft Windows XP Professional Service Pack 2 (SP2)

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size       File name
   --------------------------------------------------------
   24-Mar-2005  21:14  5.1.2600.2621  1,241,088  Ole32.dll        
   24-Mar-2005  21:11  5.1.2600.2621    555,520  Rpcrt4.dll       
   24-Mar-2005  21:14  5.1.2600.2621    256,000  Rpcss.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

The following sequence of events occurs between the client and the server:
  1. The COM+ application client connects to the Remote Procedure Call Service (RPCSS) and then sends a request.
  2. The RPCSS starts processing the request.
  3. The application client calls the RpcAsyncCancelCa function to cancel a COM+ method. The following communication occurs between the COM+ application client and the COM+ application server:
    1. The RPCSS sends a cancel request to the application server by using the NtRequestPort function. This function does not wait for a response.
    2. The application server marks the call to the RpcAsyncCancelCa function as cancel pending.
    3. The application server fails the call to the RpcAsyncCancelCa function. Then, the application notifies the OLE process that the call is completed.
    4. The application client calls the I_RpcReceive and I_RpcFreeBuffer functions. This behavior causes the call to the RpcAsyncCancelCa function to be cleaned up and removed from the client association.
  4. The application server sends a response to the client .
  5. The client receives the response. Then, it rejects the response with error 1727 (RPC_S_CALL_FAILED_DNE) because it no longer knows about this call to the RpcAsyncCancelCa function.
  6. The application server receives the error and then closes the Local Procedure Call (LPC) port.
  7. The application client notices that the LPC port is closing, and the client cleans up the association. This step is when the context rundown occurs.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbRPC kbBug kbfix kbHotfixServer kbQFE KB889178 kbAudDeveloper