Your computer does not start and you receive a "Stop 0xC000021a" error message in Windows Server 2003 (889088)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems

SYMPTOMS

When your Microsoft Windows Server 2003 computer tries to start, it may stop responding. Additionally, you may receive an error message that is similar to the following:
STOP 0xC000021a (Fatal System Error)
The Windows Logon process system process terminated unexpectedly with a status of 0xc0000354(0x00000000 0x00000000).
The system has been shut down.

CAUSE

This problem occurs when The RunDiagnosticLoggingGlobal registry entry is enabled, and one of the following conditions is true:
  • The computer belongs to an organizational unit (OU) that has the Block Policy inheritance Group Policy option enabled.
  • A user who belongs to an OU that has the Block Policy inheritance Group Policy option enabled logs on to the computer.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, 32-bit editions

   Date         Time   Version            Size  File name
   -------------------------------------------------------------------
   06-Nov-2004  01:11  5.2.3790.231    756,224  Userenv.dll

Windows Server 2003, Enterprise Edition for Itanium-based Systems

   Date         Time   Version            Size  File name     Platform
   -------------------------------------------------------------------
   06-Nov-2004  01:11  5.2.3790.231  1,546,240  Userenv.dll      IA-64
   06-Nov-2004  01:11  5.2.3790.231    756,224  Wuserenv.dll       x86

WORKAROUND

To work around this problem, turn off the RunDiagnosticLoggingGlobal registry entry. To do this, follow these steps:
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate and then click the following registry key:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Diagnostics

  3. In the right pane, right-click RunDiagnosticLoggingGlobal, and then click Modify.
  4. In the Value data box, change 1 to 0, and then click OK.
  5. Quit Registry Editor.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbWinServ2003preSP1fix KB889088 kbAudITPRO