You receive output schema validation error messages when you use the BizTalk Adapter for mySAP Business Suite to integrate data from a SAP system to BizTalk Server 2004 (889070)



The information in this article applies to:

  • Microsoft BizTalk Server 2004 Standard Edition
  • Microsoft BizTalk Server 2004 Partner Edition
  • Microsoft BizTalk Server 2004 Enterprise Edition
  • Microsoft BizTalk Server 2004 Developer Edition
  • Microsoft BizTalk Adapter 2.0 for mySAP Business Suite

SYMPTOMS

When you use the Microsoft BizTalk Adapter 2.0 for mySAP Business Suite to integrate data from a SAP system to Microsoft BizTalk Server 2004, you may receive output schema validation error messages that are similar to the following:
The 'ELEMENTNAME' element has an invalid value according to its data type.

CAUSE

This problem may occur if the SAP schema fields receive special characters such as the slash mark (/) character and the X character. This problem occurs because the BizTalk Adapter for mySAP Business Suite does not handle special characters correctly.

Note The slash mark character indicates that SAP should replace the value with a specific default value. The X character indicates that SAP should mark the corresponding value for deletion.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft BizTalk Server 2004 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Microsoft BizTalk Server 2004 Service Pack 1 (SP1) installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, you must restart the BizTalk Service to apply the changes after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version    Size    File name
   --------------------------------------------------------
   16-Nov-2004  16:50  2.0.322.0  92,880  Sapidocschema.dll
Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbBTSAdapters kbBizTalk2004preSP1fix kbbug kbfix kbHotfixServer kbQFE KB889070 kbAudDeveloper