"An error occurred while changing the IP address" error message appears when you use the Change IP Address Tool in Windows Small Business Server 2003 (889028)



The information in this article applies to:

  • Microsoft Windows Small Business Server 2003, Premium Edition
  • Microsoft Windows Small Business Server 2003, Standard Edition

SYMPTOMS

When you use the Change IP Address Tool to change the IP address that is assigned to the Server Local Area Connection network connection in Microsoft Windows Small Business Server 2003, you experience all the following symptoms:
  • You receive the following error message:
    An error occurred while changing the IP address. Your server might be partially configured. We recommend that you run the Change IP Address Tool again and enter the original IP address of the server.

    If this error message appears again, ensure that the local network adapter is enabled in Network Connections and that it is connected to a switch or hub that has power. Also, open Services, and ensure that any services having a startup type of Automatic are running.

    If the error message still occurs, see the log file at C:\Program Files\Microsoft Windows Small Business Server\Support\Changeiplog.txt.
    When you click OK, the Change IP Address Tool quits.
  • If you view the Internet Protocol (TCP/IP) Properties dialog box for the Server Local Area Connection network connection, you notice that the IP address has been changed successfully.
  • If you run the Dynamic Host Configuration Protocol (DHCP) Microsoft Management Console (MMC) snap-in to view the contents of the Address Pool folder under the DHCP scope of your Windows Small Business Server-based computer, you notice that an exclusion entry is not created for the new IP address that you configured.
  • If you run the DNS MMC snap-in to view the contents of the Windows Small Business Server forward lookup zone, you notice that the host (A) record for your Windows Small Business Server-based computer is not updated with the IP address that you configured.

CAUSE

This problem occurs if the following conditions are true:
  • The Windows Small Business Server Client Deployment component is not installed.
  • The %SBSPROGRAMDIR%\ClientSetup\Clients\Setup folder is removed or renamed.
The Windows Small Business Server Client Deployment component creates a Config.dat file in the following folder:

%SBSPROGRAMDIR%\ClientSetup\Clients\Setup

This file is used by the Set Up Computer Wizard to configure client computers on the Windows Small Business Server network.

This problem occurs because the Change IP Address Tool must write to the Config.dat file. If the Client Deployment component is not installed, or if the %SBSPROGRAMDIR%\ClientSetup\Clients\Setup folder is missing or renamed, the Change IP Address Tool cannot write to the Config.dat file.

RESOLUTION

To resolve this problem, use one of the following methods.

Method 1: Install the Client Deployment component

  1. Click Start, point to Control Panel, and then click Add or Remove Programs.
  2. In the Currently installed programs list, click Windows Small Business Server 2003, and then click Change/Remove.
  3. In the Windows Small Business Server Setup program, click Next two times.
  4. Click Maintenance on the Action menu next to Server Tools.
  5. Click Install on the Action menu next to Client Deployment, and then click Next.

    Note You do not have to install the Microsoft Internet Explorer 6.0 or Microsoft Office Outlook 2003 components that appear under Client Deployment.
  6. Click Next three times, and then click Finish on the Finishing Your Installation page of the Windows Small Business Server Setup program.
  7. Restart your computer if you are prompted to do this.
  8. Run the Change IP Address Tool to change the IP address of your Windows Small Business Server-based computer. To do this, follow these steps:
    1. Start the Server Management tool.
    2. Expand Standard Management, and then click Internet and E-mail.
    3. In the right pane, click Change Server IP Address.

Method 2: Manually create the Setup folder

  1. Click Start, click Run, type cmd, and then click OK.
  2. Type the following command, and then press ENTER:

    cd %sbsprogramdir%

    Note This command changes the Setup folder to the folder that is defined by the SBSPROGRAMDIR environment variable. By default, this is the following folder:

    C:\Program Files\Microsoft Windows Small Business Server

  3. Type the following command, and then press ENTER:

    mkdir clientsetup\clients\setup

    Note This command creates the following folder structure:

    %SBSPROGRAMDIR%\ClientSetup\Clients\Setup

  4. Run the Change IP Address Tool to change the IP address of your Windows Small Business Server-based computer. To do this, follow these steps:
    1. Start the Server Management tool.
    2. Expand Standard Management, and then click Internet and E-mail.
    3. In the right pane, click Change Server IP Address.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

885684 "Please reconfigure a different IP address" error message and the OK button becomes unavailable when you use the Change IP Address Tool in Windows Small Business Server 2003



For additional information about how to configure Windows Small Business Server, see the Windows Small Business Server product documentation. To do this, visit the following Microsoft Web site:

Modification Type:MajorLast Reviewed:11/11/2004
Keywords:kberrmsg kbpending kbBug kbtshoot kbprb KB889028 kbAudITPRO