You receive an exception error when the MCF tries to insert alerts in MOM 2005, or event ID 10042 is written to the Application log when you use the MMPC (889017)



The information in this article applies to:

  • Microsoft Operations Manager 2005

SYMPTOMS

When the MOM Connector Framework (MCF) tries to insert alerts in Microsoft Operations Manager (MOM) 2005, you receive the following exception error:
System.Web.Services.Protocols.SoapException: Exception of type System.Web.Services.Protocols.SoapException was thrown. --> ServerRoleInstance cannot be NULL or an empty string when ProblemState is set to Active or Inactive.
Parameter name: ServerRoleInstance at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall) at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters) at ConnectorServiceV2.InsertAlerts(Guid registrationId, AlertInsert[] alerts)
When you use the MOM to MOM Product Connector (MMPC), the following event appears in the Windows Application log on the server that is forwarding the alert:Source: MOM to MOM Connector
Type: Error
Event ID: 10042

Inserting data threw an ArgumentException. Invalid data.

MOM master management group:
Name_of_Management_Group

Error on: http://Destination_Server_Name:1271/connectorservicev2.asmx

Message:
System.Web.Services.Protocols.SoapException : Exception of type System.Web.Services.Protocols.SoapException was thrown. --> ServerRoleInstance cannot be NULL or an empty string when ProblemState is set to Active or Inactive. Parameter name: ServerRoleInstance

Call stack:
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall) at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters) at Microsoft.EnterpriseManagement.Mom.Connector.V2.WSDL.MCFWebServiceWSDLV2004.InsertAlerts(Guid registrationId, AlertInsert[] alerts) at Microsoft.EnterpriseManagement.Mom.Connector.V2.FrameworkWebServiceProxy.InsertAlerts(Guid registrationId, AlertInsert[] alerts) at Microsoft.ServerManagement.MOM.MomConnector.ServiceWorker.InsertNewData(Data data, DataChanges dataChanges)

CAUSE

This problem occurs if the MCF generates a state alert where one of the following conditions is true:
  • The ServerRoleInstance alert attribute value is NULL.
  • The ServerRoleInstance alert attribute value causes a MOM function to evaluate as NULL. For example, it causes the fn_InstanceName function to evaluate as NULL.
The ProblemState, the ServerRole, and the ServerRoleInstance alert attribute values are used in a state alert in MOM 2005. An alert where the ServerRoleInstance alert attribute value is NULL causes the MCF to generate an exception. Therefore, the alert is not inserted into the MOM database.

When you use the MMPC, the alert prevents the forwarding of all alerts until a set bookmark is called to clear alerts from the cache. However, using a set bookmark causes other alerts to be removed before forwarding has occurred.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Operations Manager 2005. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

905416 How to obtain the latest Microsoft Operations Manager 2005 service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Operations Manager 2005 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   18-Nov-2004  21:07  6.0.2800.1106     133,352  Mom2005-rtm-kb889017-x86-enu.exe
After the fix is installed, the following files will have the listed attributes or later:
   Date         Time   Size     File name
   -------------------------------------------
   17-Nov-2004  15:10  142,848  Q889017.msp
   18-Oct-2004  04:52  118,784  Update~1.exe 

Installation instructions

You must install this hotfix on each computer that meets both of the following conditions:
  • The MCF is running on the computer.
  • The computer receives alerts by using the MCF from the MMPC, from a Microsoft resource kit connector, or from any third-party connector.
To install this hotfix, follow these steps:
  1. Copy Mom2005-rtm-kb889017-x86-enu.exe to a local folder or to a network shared folder. If you use a network shared folder, make sure that you can access the folder from the computers that requires this hotfix.
  2. Log on as an administrator to one of the computers that requires this hotfix.
  3. Run Mom2005-rtm-kb889017-x86-enu.exe. You can run the file at a command prompt. Or, you can run it by using Windows Explorer.
  4. Stop and then restart the World Wide Web Publishing service on the computer.
  5. Repeat steps 2 through 4 on each computer that requires this hotfix.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Operations Manager 2005 Service Pack 1.

MORE INFORMATION

For more information about other problems that are resolved by Microsoft Operations Manager 2005 Service Pack 1, click the following article number to view the article in the Microsoft Knowledge Base:

905420 List of bugs that are fixed in Microsoft Operations Manager 2005 service packs

For additional information about standard terminology used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer ATdownload kbGetSP kbBug kbOpmanAlerts kbOpman2005bug kberrmsg kbfix KB889017 kbAudITPRO