Your IDE storage device may become unavailable after you change the transfer mode of another device on the same IDE channel (889003)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition


SYMPTOMS

When you change the transfer mode of an integrated device electronics (IDE) storage device from Programmed Input/Output (PIO) to ultra direct memory access (UDMA) or to direct memory access (DMA), other devices that are on the same IDE channel may become unusable. For example, the affected IDE device may not be recognized, or data on the device may not be available.

If you revert the data transfer mode back to the original configuration, the affected device works correctly again.

CAUSE

This problem may occur if the following conditions are true:
  • The affected storage device does not support variable mode block size
  • The affected storage device contains storage media that reports block size as the default block size.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Windows Server 2003

Restart requirement

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. 32-bit versions of Windows Server 2003
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   05-Nov-2004  22:39  5.2.3790.230      177,152  Ntmsdba.dll      
   05-Nov-2004  22:39  5.2.3790.230      445,440  Ntmssvc.dll      
   19-Sep-2004  11:41  5.2.3790.212       59,392  Ws03res.dll 
64-bit versions of Windows Server 2003
   Date         Time   Version              Size    File name        Platform
   --------------------------------------------------------------------------
   05-Nov-2004  22:39  5.2.3790.230      452,096    Ntmsdba.dll      IA-64
   05-Nov-2004  22:39  5.2.3790.230    1,273,856    Ntmssvc.dll      IA-64
   19-Sep-2004  09:43  5.2.3790.212       58,880    Ws03res.dll      IA-64
   19-Sep-2004  11:41  5.2.3790.212       59,392    Wws03res.dll     x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbWinServ2003preSP1fix KB889003 kbAudITPRO