FIX: The "301" shutdown event may not be correctly logged to the event log in Windows Media Services 9 Series (888905)



The information in this article applies to:

  • Microsoft Windows Media Services 9 Series

SYMPTOMS

When the Microsoft Windows Media Services (WMS) 9 Series service is stopped in a normal manner, the service is supposed to write a "301" shutdown event to the event log. When the "301" shutdown event is written to the event log, this documents the shutdown. Typically, the event log entry is supposed to look similar to the following:

Event Type: Information
Event Source: WMServer
Event Category: Multimedia
Event ID: 301
Date: 28/10/2004
Time: 15:14:09
User: N/A
Computer: MACHINENAME
Description: The Windows Media service has stopped. For more information, see Help and Support Center at http://support.microsoft.com.

On some computers, you may not see the shutdown event consistently logged. However, the service does terminate without incident.

CAUSE

This problem is caused by a race condition in the shutdown sequence of WMS. On some computers, the main server thread is terminated before the shutdown event is successfully written to the event log.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next release that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The following file is available for download from the Microsoft Download Center:
DownloadDownload the WindowsMedia9-KB888905-v2-x86-ENU.exe package now.

For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to obtain Microsoft support files from online services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   19-Nov-2004  05:29  9.0.0.3387         35,328  Wmserver.exe     

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Steps to reproduce the problem

  1. At a command prompt, type net stop wmserver.
  2. At a command prompt, type net start wmserver.
  3. Examine the event log. Verify whether the "300" startup events are not in parity with the "301" shutdown events.
  4. Repeat steps 1 through 3 until the error occurs.

Modification Type:MajorLast Reviewed:9/22/2006
Keywords:kbtshoot kbBug kbfix KB888905 kbAudDeveloper kbAudEndUser kbAudITPRO kbAudOEM