You receive a "The configuration key was not found" error message when you try to start Virtual Server 2005 (888852)



The information in this article applies to:

  • Microsoft Virtual Server 2005

SYMPTOMS

When you try to start Microsoft Virtual Server 2005, you receive the following error message:
The operation could not be completed because an unexpected error occurred. The configuration key was not found.
You may experience this issue after the host computer has unexpectedly restarted or after a major operating system configuration change has occurred.

CAUSE

This issue may occur if one or more of the following conditions are true:
  • The permissions to the following folder have been modified:

    %ALLUSERSPROFILE%\Application Data\Microsoft\Virtual Server

  • The files in this folder or in subfolders of this folder have been modified.
  • Links in this folder or in subfolders of this folder point to destination files that have been modified.

    Note By default, links in these folders point to files in the %ALLUSERSPROFILE%\Documents folder.

RESOLUTION

To troubleshoot this issue, configure file and folder permissions, and then re-create any configuration files that may be damaged. To do this, follow these steps.

Note These steps do not reset the file and folder permissions to their default states. However, these steps resolve this issue by creating sufficient rights to the files and folders for the following three accounts:

Administrators
NETWORK SERVICE
SYSTEM

Step 1: Assign Full Control permissions to the Virtual Server files and folders



By default, the Administrators group, the NETWORK SERVICE account, and the SYSTEM account have Full Control access control list (ACL) entries configured on the Virtual Server folder and on the files and folders that are contained in this folder.

Assign permissions to the %ALLUSERSPROFILE%\Application Data\Microsoft\Virtual Server folder and to all the files and folders that are in this folder. To do this, follow these steps:
  1. Start Windows Explorer, type %ALLUSERSPROFILE%\Application Data\Microsoft in the Address bar, and then click Go.
  2. Right-click Virtual Server, and then click Sharing and Security.
  3. Click the Security tab.
  4. Click Administrators, click Full Control in the Allow column, click NETWORK SERVICE, click Full Control in the Allow column, click SYSTEM, and then click Full Control in the Allow column.
  5. Click Apply, and then click OK.
  6. Right-click each file or folder that is under the Virtual Server folder to make sure that the following accounts have Full Control permissions assigned:

    Administrators
    NETWORK SERVICE
    SYSTEM

  7. Restart the Virtual Server service.
If this issue is not resolved, continue to "Step 2: Determine which files or folders may be damaged."

Step 2: Determine which files or folders may be damaged

If the Virtual Server service does not start, move the Virtual Machines folder and the Virtual Networks folder from the Virtual Server folder, and then re-create these folders.

Important You must use the MOVE command to move these folders. In this scenario, do not copy the folders to a new location and then delete the original folders. For additional information about how to move a folder by using the MOVE command, type move /? at a command prompt.

To move and then re-create these folders, follow these steps:
  1. Click Start, click Run, type cmd, and then click OK.
  2. Type the following commands in order. Press ENTER after each command.

    move "%allusersprofile%\application data\microsoft\virtual server\virtual machines" c:\

    move "%allusersprofile%\application data\microsoft\virtual server\virtual networks" c:\

    cd %allusersprofile%\application data\microsoft\virtual server

  3. Type md "Virtual Machines", and then press ENTER.
  4. Type md "Virtual Networks", and then press ENTER.
  5. Restart the Virtual Server service.
If the Virtual Server service does not start, the Options.xml file may be damaged. If the Virtual Server service starts successfully, determine which file in the Virtual Machines folder or which file in the Virtual Networks folder is damaged. To troubleshoot this issue, use one of the following cases depending on whether the Virtual Server service starts successfully:

Case 1: The Virtual Server service does not start successfully

Assume that the Virtual Server service does not start after you move the Virtual Machines folder and the Virtual Networks folder to a new location and create new empty folders in the Virtual Server folder. In this case, the Options.xml file may be damaged.

To resolve this issue, follow these steps:
  1. Remove the empty Virtual Machines folder and the empty Virtual Networks folder from the Virtual Server folder. To do this, start Windows Explorer, right-click each folder, click Delete, and then click Yes on the following message that appears: Are you sure you want to remove the folder 'Virtual Machines' and move all its contents to the Recycle Bin?
  2. Move the original Virtual Machines folder and the original Virtual Networks folder back to the Virtual Server folder. To do this, follow these steps:
    1. Click Start, click Run, type cmd, and then click OK.
    2. Type the following commands in order. Press ENTER after each command.

      move "c:\virtual machines" "%allusersprofile%\application data\microsoft\virtual server"

      move "c:\virtual networks" "%allusersprofile%\application data\microsoft\virtual server"

  3. Move the Options.xml file to a new location. To do this, follow these steps:
    1. Click Start, click Run, type cmd, and then click OK.
    2. Type the following command, and then press ENTER:

      move "%allusersprofile%\application data\microsoft\virtual server\Options.xml" c:\

  4. Start the Virtual Server service.
When you start the Virtual Server service, a new Options.xml file is automatically created. You can then re-create the settings in this file by using the options on the Virtual Server Administration Website Web page.

Note To view the configuration settings for this file, use a text editor, such as Notepad, to open the Options.xml file that you moved from the Virtual Server folder.

Case 2: The Virtual Server service starts successfully

Assume that the Virtual Server service starts after you move the Virtual Machines folder and the Virtual Networks folder to a new location and create new empty folders in the Virtual Server folder. In this case, a file in the Virtual Machines folder or in the Virtual Networks folder may be damaged. To troubleshoot this issue, follow these steps:
  1. Stop the Virtual Server service.
  2. Move the Virtual Networks folder back to the Virtual Server folder, and then start the Virtual Server service.
  3. If the Virtual Server service does not start, move the files from the Virtual Networks folder to a new location, one at a time. Try to restart the Virtual Server service after you move each file. If you determine which file, when removed, enables the Virtual Server service to start, re-create that file by using the Create option under Virtual Networks in the Virtual Server Administration Website Web page.

    Note You can view the configuration information for this virtual network by viewing the information in the network-related file that you removed from the Virtual Networks folder.
  4. If the Virtual Server service starts successfully, stop the Virtual Server service, and then move the Virtual Machines folder back to the Virtual Server folder.
  5. Move all the files except for one file from the Virtual Machines folder to a new location, and then try to start the Virtual Server service.
  6. If the Virtual Server service starts successfully, stop the Virtual Server service, and then move the Virtual Machine files back to the Virtual Machines folder, one at a time. Try to start the Virtual Server service after you restore each virtual machine file.
  7. When you determine which file prevents the Virtual Server service from starting successfully, move this file from the Virtual Machines folder. Re-create this virtual machine file by using the Create option under Virtual Machines on the Virtual Server Administration Website Web page.

Modification Type:MajorLast Reviewed:12/20/2004
Keywords:kbprb kbtshoot kbHardware kbenv KB888852 kbAudITPRO