You may experience poor performance when you access a virtual machine that is on a remote computer by using an RDP client or a Terminal Services session (888759)



The information in this article applies to:

  • Microsoft Virtual Server 2005

SYMPTOMS

When you access a Microsoft Virtual Server 2005 virtual machine that is on a remote computer by using a Remote Desktop Protocol (RDP) client or a Terminal Services session, you may experience poor performance. For example, the screen may redraw gradually and the mouse pointer may move slowly.

CAUSE

This behavior may occur because hardware acceleration is set low on one or more of the computers in the session.

Note By default, Microsoft Windows Server 2003 sets hardware acceleration to the next to lowest setting.

This behavior may also occur when the pointer shadow is enabled or when pointer trails are set to display on one or more computers in the session.

RESOLUTION

To resolve this behavior, increase the hardware acceleration on each computer that is involved in the session. For example, increase the hardware acceleration on the host computer, the guest computer, and the RDP client computer. Additionally, turn off the pointer shadow and the pointer trails on each computer in the session.

Follow these steps to increase the hardware acceleration on each computer in the session:
  1. Click Start, click Run, type desk.cpl in the Open box, and then click OK.
  2. Click the Settings tab, click Advanced, and then click the Troubleshoot tab.
  3. Drag the slider all the way to the right.

    Note The following text displays under the hardware acceleration scale when the slider is positioned at Full:

    All accelerations are enabled. Use this setting if your computer has no problems. (Recommended)

  4. Click OK two times.
Follow these steps to turn off the pointer shadow and the pointer trails on each computer in the session:
  1. Click Start, click Run, type main.cpl in the Open box, and then click OK.
  2. Click the Pointers tab, and then click to clear Enable pointer shadow.
  3. Click the Pointer Options tab, click to clear Display pointer trails, and then click OK.

Modification Type:MajorLast Reviewed:11/29/2004
Keywords:kbwinservperf kbTermServ kbtshoot kbprb KB888759 kbAudITPRO kbAudEndUser