TN3270 clients cannot connect to the TN3270 Server after a configuration change is made to the TN3270 Server (888611)



The information in this article applies to:

  • Microsoft Host Integration Server 2004


SYMPTOMS

In Microsoft Host Integration Server 2004, TN3270 clients cannot connect to a TN3270 Server after an administrator makes a configuration change to the TN3270 Server while the TN3270 service is active. TN3270 clients that were connected to the TN3270 Server before the configuration change was made are unaffected. The following event is logged by the TN3270 Server when a TN3270 client tries to connect to the TN3270 Server after the configuration change: Event ID: 1070
Source: TN3270 Server
Description: No security record available for port 23
Explanation: A connection has been rejected, either due to a bad configuration or a failing to authenticate a client certificate.
Action: Check that the client certificate is valid and that the port security is correctly configured.Note This problem occurs even if the TN3270 Server is not configured to support SSL encryption.

CAUSE

This problem occurs because the internal SSL queue is not refreshed correctly when the configuration is reread.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Host Integration Server 2004 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
      Date         Time   Version            Size    File name
   --------------------------------------------------------------
   09-Nov-2004  22:21  6.0.1914.0        241,664  Tn3servr.exe    


				

Note Because of file dependencies, the most recent fix that contains these files may also contain additional files.

WORKAROUND

If the TN3270 Server is stopped and restarted after you make the configuration change, TN3270 clients can connect to the TN3270 Server.

Note If you stop the TN3270 Server, all users who currently have TN3270 sessions through the TN3270 Server will be disconnected.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:6/5/2006
Keywords:kbHotfixServer kbQFE kbfix kbbug KB888611 kbAudDeveloper kbAudITPRO