The Ldifde.exe tool may not export all group members when you export from multiple groups that contain many members in Windows 2000 or in Windows Server 2003 (888249)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

The Ldifde.exe tool may not export all group members when you export from multiple groups that contain many members. For example, this scenario occurs when the following conditions are true:
  • You use the Ldifde.exe tool to export multiple groups.
  • On a Microsoft Windows 2000-based domain controller, one or more of the groups that are included in the export contain more than 1000 group members. Alternatively, on a Microsoft Windows Server 2003-based domain controller, one or more of the groups that are included in the export contain more than 1500 group members.
For each group that contains more than 1000 group members in Windows 2000, only the first 1000 group members will appear in the export list. For each group that contains more than 1500 members in Windows Server 2003, only the first 1500 group members will appear in the export list.

Because the membership list is not sorted alphabetically, the missing group members may appear to be arbitrary.

CAUSE

Windows 2000 exports group members in batches of 1000 entries. Windows Server 2003 exports group members in batches of 1500 entries. The Lightweight Directory Access Protocol (LDAP) server queries additional group members by using a ranged attribute specification. The LDAP server will quit a query for additional group members if the server encounters a group that has fewer values than are identified in the attribute specification range.

RESOLUTION

Windows 2000 hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version              Size  File name
   --------------------------------------------------------------
   24-Mar-2004  02:17  5.0.2195.6876     388,368  Advapi32.dll     
   24-Mar-2004  02:17  5.0.2195.6866      69,904  Browser.dll      
   24-Mar-2004  02:17  5.0.2195.6824     134,928  Dnsapi.dll       
   24-Mar-2004  02:17  5.0.2195.6876      92,432  Dnsrslvr.dll     
   24-Mar-2004  02:17  5.0.2195.6883      47,888  Eventlog.dll     
   24-Mar-2004  02:17  5.0.2195.6890     143,632  Kdcsvc.dll       
   11-Mar-2004  02:37  5.0.2195.6903     210,192  Kerberos.dll     
   21-Sep-2003  00:32  5.0.2195.6824      71,888  Ksecdd.sys
   15-Oct-2004  18:16  5.0.2195.6987     513,296  Lsasrv.dll       
   25-Feb-2004  23:59  5.0.2195.6902      33,552  Lsass.exe        
   11-Mar-2004  02:37  5.0.2195.6897     123,152  Msv1_0.dll       
   10-Jun-2004  16:58  5.0.2195.6949     309,008  Netapi32.dll     
   24-Mar-2004  02:17  5.0.2195.6891     371,472  Netlogon.dll     
   20-Dec-2004  09:15  5.0.2195.7011     937,744  Ntdsa.dll        
   24-Mar-2004  02:17  5.0.2195.6897     388,368  Samsrv.dll       
   24-Mar-2004  02:17  5.0.2195.6893     111,376  Scecli.dll       
   24-Mar-2004  02:17  5.0.2195.6903     253,200  Scesrv.dll       
   02-Dec-2004  14:27  5.0.2195.7004   6,272,512  Sp3res.dll       
   24-Mar-2004  02:17  5.0.2195.6824      50,960  W32time.dll      
   21-Sep-2003  00:32  5.0.2195.6824      57,104  W32tm.exe        

Windows Server 2003 hotfix information

There is no hotfix available for Windows Server 2003.

WORKAROUND

To work around this problem, you must export a single group at a time. For additional information about how to use the Ldifde.exe tool, click the following article number to view the article in the Microsoft Knowledge Base:

237677 Using LDIFDE to import and export directory objects to Active Directory

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbBug kbfix kbWin2000preSP5fix kbHotfixServer kbQFE KB888249 kbAudITPRO