Event ID 1080 is repeatedly logged on your Windows 2000 Advanced Server-based computer that is part of a server cluster (888200)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

On your Microsoft Windows 2000 Advanced Server-based computer that is part of a server cluster, the Cluster service logs the following event in the System log every 10 to 15 seconds:Type: Error
Event ID: 1080
Source: ClusSvc
Description:
The Microsoft Clustering Service could not write file (C:\DOCUME~1\exchange\LOCALS~1\Temp\CLS27FB.tmp). The disk may be low on diskspace, or some other serious condition exists. Additionally, the Cluster.log file shows entries that are similar to the following entries that have been wrapped for readability:
000006b0.000008f0::2001/11/13-00:21:34.171 [CP] CppCheckpoint failed to get registry 
database SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem to file 
C:\DOCUME~1\exchange\LOCALS~1\Temp\CLS9F5.tmp error 1018

000006b0.000008f0::2001/11/13-00:21:31.625 [CP] CppCheckpoint failed to get registry 
database SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersNetIf to file 
C:\DOCUME~1\exchange\LOCALS~1\Temp\CLS9F4.tmp error 1018

000006b0.000008f0::2001/11/13-00:21:31.625 [CP] CppCheckpoint failed to get registry 
database SYSTEM\CurrentControlSet\Services\MSExchangeIS\Diagnostics to file 
C:\DOCUME~1\exchange\LOCALS~1\Temp\CLS9F3.tmp error 1018

000006b0.000008f0::2001/11/13-00:21:31.187 [CP] CppCheckpoint failed to get registry 
database SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate to file 
C:\DOCUME~1\exchange\LOCALS~1\Temp\CLS9F2.tmp error 1018

000006b0.000008f0::2001/11/13-00:21:31.171 [CP] CppCheckpoint failed to get registry 
database SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersPublic to file 
C:\DOCUME~1\exchange\LOCALS~1\Temp\CLS9F1.tmp error 1018
Note By default, the Cluster.log file is located in the %windir%\Cluster folder.

CAUSE

This issue occurs if the following conditions are true:
  • You are running Microsoft Exchange Server on your server cluster.
  • The registry subkeys that are mentioned in the Cluster.log file entries were flagged for deletion.
Note Error 1018 in the Cluster.log file indicates that an operation that was not valid was tried on a registry subkey that has been marked for deletion.

RESOLUTION

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this issue, follow these steps:
  1. Use the Cluster Administrator program to take the appropriate cluster resource offline. To determine the cluster resource to take offline, locate the entries in the Cluster.log file that are similar to the entries that are listed in the Symptoms section. From the log file entries, you can determine the registry subkey or subkeys that are causing the issue. For example, the Cluster.log entries that are listed in the Symptoms section indicate that the issue is occurring with various subkeys that are under the MSExchangeIS subkey. After you identify the affected subkeys, follow these steps:
    1. Click Start, point to Programs, point to Administrative Tools, and then click Cluster Administrator.
    2. Expand Groups, and then click the resource group that contains the Exchange cluster resources.
    3. In the right pane, right-click the resource that corresponds to the registry subkey that is identified in the Cluster.log file, and then click Take Offline. Use the following guidelines:
      • If the Cluster.log file entries indicate that this issue is occurring with subkeys that are under the MSExchangeIS subkey, right-click the Exchange Information Store Instance, and then click Take Offline.

        Note If you are using Microsoft Exchange Server 5.5, the resource name appears as Microsoft Exchange Information Store.
      • If the Cluster.log file entries indicate that this issue is occurring with subkeys that are under the MSExchangeSA subkey, right-click the Exchange System Attendant resource, and then click Take Offline. Note that if you take the Exchange System Attendant resource offline, the dependent Exchange resources are also taken offline.

        Note If you are using Exchange Server 5.5, the resource name appears as Microsoft Exchange System Attendant.
      • If the Cluster.log file entries indicate that this issue is occurring with subkeys that are under the MSExchangeMTA subkey, right-click the Exchange Message Transfer Agent Instance, and then click Take Offline.

        Note If you are using Exchange Server 5.5, the resource name appears as Microsoft Exchange Message Transfer Agent.
      • If the Cluster.log file entries indicate that this issue is occurring with subkeys under the MSExchangeDS subkey, right-click Microsoft Exchange Directory, and then click Take Offline.

        Note The MSExchangeDS subkey is only present on a server that is running Exchange Server 5.5.
  2. Start Registry Editor on the active node. To do this, click Start, click Run, type regedit, and then click OK.

    Note For this procedure, you must start Registry Editor by using the regedit command. Do not use the regedt32 command.
  3. Locate and then click the registry subkey that is identified in the Cluster.log file entries. Use the following guidelines.

    Note The subkey must correspond with the Exchange resource that you took offline in step 1.
    • If the Cluster.log file entries indicate that this issue is occurring with subkeys that are under the MSExchangeIS subkey, locate and then click HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS.
    • If the Cluster.log file entries indicate that this issue is occurring with subkeys that are under the MSExchangeSA subkey, locate and then click HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeSA.
    • If the Cluster.log file entries indicate that this issue is occurring with subkeys that are under the MSExchangeMTA subkey, locate and then click HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeMTA.
    • If the Cluster.log file entries indicate that this issue is occurring with subkeys that are under the MSExchangeDS subkey, locate and then click HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeDS.
  4. On the Registry menu, click Export Registry File.
  5. In the Export Registry File dialog box, specify a file name and location where you want to save the file, and then click Save.
  6. In Registry Editor, right-click the subkey that you exported in steps 4 and 5, and then click Delete. For example, if you exported the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS subkey, right-click MSExchangeIS, and then click Delete.
  7. Click Yes to confirm the deletion.
  8. Locate and then double-click the registry (.reg) file that you saved in step 5 to import the subkey back into the registry.
  9. Click Yes to add the information to the registry. Click OK when you receive a message stating that the information has been successfully entered into the registry.

    Note The delete flag should be cleared at this point.
  10. Confirm that the registry subkey was added, and then quit Registry Editor.
  11. On the second node of the cluster, click Start, click Run, type regedit, and then click OK.

    Note For this procedure, you must start Registry Editor by using the regedit command. Do not use the regedt32 command.
  12. Repeat steps 3 through 10 on the second node.
  13. Use the Cluster Administrator program to bring the cluster resource that you took offline in step 1 online again. To do this, follow these steps:
    1. Click Start, point to Programs, point to Administrative Tools, and then click Cluster Administrator.
    2. Expand Groups, and then click the resource group that contains the Exchange cluster resources.
    3. In the right pane, right-click the resource that you took offline in step 1, and then click Bring Online.

      Note If you took the Exchange System Attendant resource offline, you must also bring all the other dependent Exchange resources online.
  14. Examine the System log for any 1080 event ID messages.

MORE INFORMATION

For additional information about another potential cause of the 1080 event ID and how to reset the server cluster check points, click the following article number to view the article in the Microsoft Knowledge Base:

307469 Restore registry check points stop working after you restore a server cluster


Modification Type:MinorLast Reviewed:1/4/2006
Keywords:kbClustering kbtshoot kbprb KB888200 kbAudITPRO