The Print Spooler service unexpectedly stops when Citrix MetaFrame XP 1.0 is installed on a computer that is running Windows Server 2003 or Windows 2000 Server (888191)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows 2000 Server

SYMPTOMS

The Print Spooler service unexpectedly stops on a Microsoft Windows Server 2003-based or a Microsoft Windows 2000 Server-based computer that is also running Citrix MetaFrame XP 1.0. Additionally, the following events are repeatedly logged in the System event log:

Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7031
Date: Date
Time: Time
User: N/A
Computer: ComputerName
Description:
The Print Spooler service terminated unexpectedly


Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7036
Date: Date
Time: Time
User: N/A
Computer: ComputerName
Description:
The Print Spooler service entered the running state

The following event may also be logged in the System event log:


Event Type: Error
Event Source: Print Event
Category: None
Event ID: 54
Date: Date
Time: Time
User: NT AUTHORITY\SYSTEM
Computer: ComputerName
Description:
Document Microsoft Word -DocumentName.doc was corrupted and has been deleted. The associated driver is: PrinterName
For more information, see Help and Support Center at http://support.microsoft.com.

CAUSE

This problem occurs if the Cpmmon.dll file causes the Print Spooler service to unexpectedly stop. The Cpmmon.dll file is installed by the Citrix MetaFrame XP 1.0 program.

RESOLUTION

To resolve this problem, obtain a hotfix from one of the following Citrix Web sites.

For Windows Server 2003

For Windows 2000 Server

MORE INFORMATION

Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:9/22/2006
Keywords:kb3rdparty kbtshoot KB888191 kbAudITPRO kbAudEndUser