"Stop 0x000000B8" error message on a computer that has the Dell OpenManage Server Administrator installed in Windows Server 2003 or in Windows Small Business Server 2003 (888190)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Small Business Server 2003, Premium Edition
  • Microsoft Windows Small Business Server 2003, Standard Edition

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you start a computer that is running Microsoft Windows Server 2003 or Microsoft Small Business Server 2003, you may receive the following Stop error message:
STOP: 0x000000B8
(parameter1,parameter2,parameter3,parameter4)
ATTEMPTED_SWITCH_FROM_DPC

CAUSE

This issue occurs if Dell OpenManage Server Administrator, a Web tool for managing individual Dell PowerEdge servers, is installed on your computer.

The OpenManage Array Manager program in the Dell OpenManage Server Administrator installs a filter driver on your computer in the following location:

%SYSTEMROOT%\System32\Drivers

This filter driver file is named Afamgt.sys. The version of the Afamgt.sys filter driver that is installed on your computer may not be compatible with Windows Server 2003. In this scenario, you receive the Stop error message that is mentioned in the "Symptoms" section.

WORKAROUND

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk. To work around this issue, remove the UpperFilters registry entry that pertains to the Afamgt.sys filter driver. Then, disable the Afamgt.sys filter driver. To do this, follow these steps:
  1. Start your computer in Safe mode. To do this, follow these steps.

    Note Generally, the computer automatically starts in Safe mode after a "Stop 0x000000B8" error occurs.
    1. Restart your computer, and then immediately hold down the F8 key.
    2. On the Windows Advanced Options menu, use your UP ARROW and DOWN ARROW keys to select Safe Mode, and then press ENTER.
    3. Select the installation that you want to start, and then press ENTER

      Note The words "Safe Mode" appear in blue at the bottom of the screen.
  2. Click Start, click Run, type regedit in the Open box, and then click OK.
  3. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{4D36E967-E325-11CE-BFC1-08002 BE10318}

  4. In the right pane, double-click UpperFilters.
  5. In the Edit Multi-String dialog box, delete the "Afamgt" entry that is listed in the Value data box.

    Note Leave the "PartMgr" and the "Diskperf" entries that are listed in the Value data box.
  6. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Afamgt

  7. In the right pane, double-click Start.
  8. In the Value data box, type 4, and then click OK.
  9. Quit Registry Editor.
  10. Restart your computer.

MORE INFORMATION

Contact Dell Computer to obtain the OMClean utility and to install the latest version of the Afamgt.sys filter driver.

Note The OMClean utility removes all instances of the OpenManage Server Administrator Web tool. For information about how to contact Dell Computer, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and software vendor contact information, A-K

60781 Hardware and software vendor contact information, L-P

60782 Hardware and software vendor contact information, Q-Z

Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information. The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:4/5/2005
Keywords:kbtshoot KB888190 kbAudEndUser kbAudITPRO