"0xC007007e, drviis.dll won't register" error message when you install Exchange 2000 Server (888177)



The information in this article applies to:

  • Microsoft Exchange 2000 Server
  • Microsoft Exchange 2000 Enterprise Server

SYMPTOMS

When you try to install Microsoft Exchange 2000 Server, the installation may fail and you receive the following error message:
0xC007007e, drviis.dll won't register.
Additionally, if you manually register the Drviis.dll file by using the Regsvr32 tool (Regsvr32.exe), you receive the following error message:
Module not found.

CAUSE

This issue may occur if the Atl.dll file is not registered.

RESOLUTION

To resolve this issue, register the Atl.dll file. To do this, click Start, click Run, type regsvr32 Atl.dll in the Open box, and then click OK.

MORE INFORMATION

To determine whether the Atl.dll file is loading successfully, follow these steps.

Note We recommend that you follow these steps two times. Follow these steps on a computer that is functioning correctly, and then follow these steps on a computer that is experiencing the problem. Compare the results.
  1. Download the debugging tools for Windows. To do this, visit the following Microsoft Web site, and then follow the instructions:
  2. Install the debugging tools for Windows to the C:\Debugger folder.

    Note If this folder does not exist, you must create it.
  3. Click Start, click Run, type cmd in the Open box, and then click OK.
  4. Locate the C:\Program Files\exchsrvr\bin folder, type \debugger\cdb regsvr32 atl.dll, and then press ENTER.

    Note The command prompt now appears as "0:000>."
  5. At the command prompt, type g, and then press ENTER.
  6. When you receive a message that states that the registration was successful, click OK.
  7. At the command prompt, type q, and then press ENTER.

Modification Type:MinorLast Reviewed:8/26/2005
Keywords:kbsetup kbhowto kbprb KB888177 kbAudITPRO