Changes that you make to the amount of usable space on a hard disk may not be displayed in Disk Management in Windows Server 2003 (888104)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When you use Disk Management to change the amount of usable space on a hard disk in Microsoft Windows Server 2003, the updated hard disk space may not be displayed in the Disk Management user interface (UI). If you run the Rescan Disks command in Disk Management, the updated hard disk space is still not displayed in the UI. You must restart your computer before the updated hard disk space can be seen in the Disk Management UI.

CAUSE

The partition table layout of the hard disk is cached in memory, and the cached information may not be updated when you make a change in Disk Management. Sometimes, the partition table layout that is cached in memory is updated only when you restart your computer.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows Server 2003 64-bit versions
Date         Time   Version            Size    File name
-----------------------------------------------------------
27-Oct-2004  19:57  5.2.3790.228      145,920  Classpnp.sys
Windows Server 2003 32-bit versions
Date         Time   Version            Size    File name
-----------------------------------------------------------
27-Oct-2004  19:29  5.2.3790.228       61,952  Classpnp.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbDiskMemory kbBug kbfix kbWinServ2003preSP1fix KB888104 kbAudITPRO