"The security settings for the Virtual Server event log cannot be synchronized with the Virtual Server security settings" error message in Virtual Server 2005 (888027)



The information in this article applies to:

  • Microsoft Virtual Server 2005

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you use Microsoft Virtual Server 2005, the following error message may be recorded in the Application log:
The security settings for the Virtual Server event log cannot be synchronized with the Virtual Server security settings. See Virtual Server Help for more information.
This issue occurs even though sufficient user permissions are configured in Virtual Server.

CAUSE

This issue may occur because sufficient user permissions are not configured on the registry subkey that enables access to the Virtual Server event log.

RESOLUTION

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this issue, grant sufficient user permissions on the relevant registry subkey. To do this, follow these steps:
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Eventlog\Virtual Server

  3. In the left pane, right-click Virtual Server, and then click Permissions.
  4. In the Group or user names list, click the user or group that experiences the issue described in this article.
  5. Make sure that the Full Control check box in the Allow column is selected, and then click OK.
  6. Close Registry Editor.

Modification Type:MinorLast Reviewed:1/3/2005
Keywords:kbRegistry kbtshoot kbprb KB888027 kbAudITPRO