You may receive a "1607:Unable to install InstallShield Scripting runtime" error message when you try to install software in Windows XP (888019)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

SYMPTOMS

When you try to install software on a Microsoft Windows XP-based computer, the installation fails and you may receive the following error message:
1607:Unable to install InstallShield Scripting Runtime

CAUSE

This problem may occur if one of the following conditions is true:
  • You run the Setup program from a virtual drive created through the subst command.
  • The driver IDriver.exe is not registered correctly.
  • The installer Msiexec.exe is not registered correctly.
  • The user account does not have permission to access the C:\Windows\Installer folder.
  • An older version of the Windows Installer engine was installed from a network drive that is no longer available.
  • The user account does not have permission to install software on the computer.
  • Another instance of Msiexec.exe is running.
  • Another Windows Installer-based Setup program is running.
  • Windows XP is damaged.

RESOLUTION

To resolve this problem, use one of the following methods:

Reinstall the InstallScript engine

To reinstall the InstallScript engine from InstallShield Developer, follow these steps:
  1. Click Start, click All Programs, point to Accessories, and then click Windows Explorer.
  2. Open the following folder: C:\Program Files\InstallShield\Developer\Redist\Language Independent\i386.
  3. Double-click Isscrpt.msi.
  4. Follow the instructions that appear on the screen.

Running Setup from a virtual drive

If you are running the Setup program from a virtual drive created by using the SUBST command, you can delete the virtual drive and instead run the Setup program from the physical hard disk. To delete the virtual drive, click Start, click Run, type subst drive_letter: /d, and then click OK.

Register Idriver and Msiexec

To register Idriver and Msiexec, follow these steps:
  1. Click Start, click Run, type "C:\Program Files\Common Files\InstallShield\Developer\7\Intel 32\IDriver.exe" /REGSERVER, and then click OK.
  2. Click Start, click Run, type C:\Windows\System32\msiexec.exe /REGSERVER, and then click OK.

Change Permissions

Log on to the Windows XP computer with an administrator user account, and verify that you have the correct permissions for the C:\Windows\Installer folder. Follow these steps:
  1. Click Start, click All Programs, point to Accessories, and then click Windows Explorer.
  2. Click Folder Options on the Tools menu.
  3. Click the View tab.
  4. Click Show hidden files and folders, and then click OK.
  5. Locate the folder C:\Windows\Installer.
  6. Right-click the Installer folder, and then click Properties.
  7. Click the Security tab.
  8. Click System, and then verify that the Full control check box is selected.
  9. Click Administrators, and then verify that the Full control check box is selected.
  10. Click your user name, and then verify that the Full control check box is selected.

Stop other instances of Windows Installer

To stop other instances of Windows Installer, follow these steps:
  1. Right-click the taskbar, and then click Task Manager.
  2. Click the Processes tab.
  3. Click Msiexec.exe in the Processes list, and then click End Process.
  4. Click Yes.
  5. Repeat steps 3 and 4 for each instance of Msiexec.exe.
  6. Close Task Manager.

Reinstall Windows XP

For additional information about reinstalling Windows XP, click the following article number to view the article in the Microsoft Knowledge Base:

315341 How to perform an in-place upgrade (reinstallation) of Windows XP

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:5/4/2005
Keywords:kbsetup kbtshoot kbprb KB888019 kbAudEndUser