The URL of an item that is returned in the search results does not work when you search SharePoint Portal Server 2003 for content that is stored in Microsoft Commerce Server (887712)



The information in this article applies to:

  • Microsoft Office SharePoint Portal Server 2003

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

You configure Microsoft Office SharePoint Portal Server 2003 to crawl data that is stored in Microsoft Commerce Server. You search the portal site for content that is stored in Commerce Server. When you click the URL of an item that is returned in the search results, you unexpectedly cannot access that item.

CAUSE

This issue occurs if the following conditions are true:
  • The URL of the item contains a query string. The query string is the part of the URL that appears after the question mark character (?) in the URL.
  • The query string contains one or more special characters that are not encoded as an escape sequence.
SharePoint Portal Server 2003 does not use escape sequences for all special characters that are contained in the query string part of the URL. Examples of special characters that do not use an escape sequence include the following:
  • A forward slash character (/) appears as a forward slash character in the URL and is not converted to a %2F escape sequence.
  • A colon character (:) appears as a colon character in the URL and is not converted to a %3A escape sequence.

RESOLUTION

This problem was first fixed in a hotfix that is now contained in a service pack. If you installed the latest SharePoint Portal Server 2003 service pack, you do not have to install the hotfix.

Service pack information

This problem is corrected in Microsoft Office SharePoint Portal Server 2003 Service Pack 2.

To resolve this problem, obtain the latest service pack for SharePoint Portal Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

889380 How to obtain the latest service pack for SharePoint Portal Server 2003

After you install the service pack, follow the steps that are listed in the "More Information" section to set the DontUnescapeAfterPath registry entry and to enable the hotfix.

Hotfix information

How to obtain the hotfix

This issue is fixed in the SharePoint Portal Server 2003 post-Service Pack 1 Hotfix Package October 22, 2004. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

887819 Description of the SharePoint Portal Server 2003 post-Service Pack 1 hotfix package: October 22, 2004

Add the DontUnescapeAfterPath registry entry

To enable this hotfix after you install it, add the DontUnescapeAfterPath registry entry to the following registry subkey, and then set the registry entry to 1:

HKEY_LOCAL_MACHINE\Software\Microsoft\SPSSearch\Gathering Manager

When you set the DontUnescapeAfterPath registry entry to 1, special characters that are contained in the query string of the URL are formatted by using an escape sequence. If you do not want to format special characters that are contained in the query string of the URL by using an escape sequence, set the DontUnescapeAfterPath registry entry to 0 (zero), or remove the DontUnescapeAfterPath registry entry.

To enable the hotfix after you install it, follow these steps.

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
  1. Add the DontUnescapeAfterPath registry entry, and then set the registry entry to 1. To do this, follow these steps:
    1. Click Start, click Run, type regedit in the Open box, and then click OK.
    2. Locate and then click the following registry subkey:

      HKEY_LOCAL_MACHINE\Software\Microsoft\SPSSearch\Gathering Manager

    3. On the Edit menu, point to New, and then click DWORD Value.
    4. Type DontUnescapeAfterPath, and then press ENTER.
    5. Right-click DontUnescapeAfterPath, and then click Modify.
    6. Type 1 in the Value data box, and then click OK.
    7. On the File menu, click Exit to quit Registry Editor.
  2. Restart the Microsoft SharePointPS Search service. To do this, follow these steps:
    1. Click Start, click Run, type cmd in the Open box, and then click OK.
    2. Stop the Microsoft SharePointPS Search service. To do this, type net stop sharepointpssearch at the command prompt, and then press ENTER.
    3. Start the Microsoft SharePointPS Search service. To do this, type net start sharepointpssearch at the command prompt, and then press ENTER.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in SharePoint Portal Server 2003 Service Pack 2.

Modification Type:MajorLast Reviewed:7/26/2006
Keywords:kbSharePtPortalSvr2003SP2fix kbQFE KBHotfixServer kbSharePtPortalSvr2003preSP2fix kbBug kbfix KB887712 kbAudITPRO