You receive a "Logon failure" message when you use a smart card on a Windows Server 2003-based computer (887578)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition


Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you try to use a smart card to log on to a Microsoft Windows Server 2003 domain controller, you cannot log on and you may receive the following message:Logon failure

CAUSE

This problem occurs when the certificate revocation list (CRL) is outdated and a new CRL is not available. A public key infrastructure (PKI) that is not working can cause the distribution server of the CRL not to publish a new CRL. If a new CRL is not published, logons to client computers are not allowed.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003 IA-64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Crypt32.dll5.131.3790.4251,578,49614-Oct-200505:21IA-64NoneRTMQFE
Cryptnet.dll5.131.3790.425160,25614-Oct-200505:21IA-64NoneRTMQFE
Kdcsvc.dll5.2.3790.425590,33614-Oct-200505:21IA-64NoneRTMQFE
Kerberos.dll5.2.3790.425907,26414-Oct-200505:21IA-64NoneRTMQFE
Wcrypt32.dll5.131.3790.425612,86414-Oct-200505:21x86NoneWOW
Wcryptnet.dll5.131.3790.42561,95214-Oct-200505:21x86NoneWOW
Wkerberos.dll5.2.3790.425344,06414-Oct-200505:21x86NoneWOW
Crypt32.dll5.131.3790.25481,759,23214-Oct-200505:21IA-64SP1SP1QFE
Cryptnet.dll5.131.3790.2548172,54414-Oct-200505:21IA-64SP1SP1QFE
Kdcsvc.dll5.2.3790.2548613,88814-Oct-200505:21IA-64SP1SP1QFE
Kerberos.dll5.2.3790.2548963,07214-Oct-200505:21IA-64SP1SP1QFE
Wcrypt32.dll5.131.3790.2548595,96814-Oct-200505:21x86SP1WOW
Wcryptnet.dll5.131.3790.254862,46414-Oct-200505:21x86SP1WOW
Wkerberos.dll5.2.3790.2548350,72014-Oct-200505:21x86SP1WOW
x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Crypt32.dll5.131.3790.25481,428,99214-Oct-200505:21x64SP1SP1QFE
Cryptnet.dll5.131.3790.2548111,10414-Oct-200505:21x64SP1SP1QFE
Kdcsvc.dll5.2.3790.2548419,84014-Oct-200505:21x64SP1SP1QFE
Kerberos.dll5.2.3790.2548720,89614-Oct-200505:21x64SP1SP1QFE
Wcrypt32.dll5.131.3790.2548595,96814-Oct-200505:21x86SP1WOW
Wcryptnet.dll5.131.3790.254862,46414-Oct-200505:21x86SP1WOW
Wkerberos.dll5.2.3790.2548350,72014-Oct-200505:21x86SP1WOW
x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Crypt32.dll5.131.3790.425612,86414-Oct-200504:10x86NoneRTMQFE
Cryptnet.dll5.131.3790.42561,95214-Oct-200504:10x86NoneRTMQFE
Kdcsvc.dll5.2.3790.425227,84014-Oct-200504:10x86None

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
After you have installed the hotfix, the following three registry keys are made available so that you can extend the validity period of the CRL.

HKEY_Local_Machine\System\CurrentControlSet\Services\KDC\CRLValidityExtensionPeriod

This DWORD value lets you to extend the CRL validity period by a specified number of hours. When you set this value to a non-zero value, the certificate status checking code for smart card logons ignores any validity period errors as long as the CRL is not expired by more than the number of specified hours. This extension of the validity period only applies to CRLs that are used during the evaluation of certificates used for smart card logon. For example, this extension would apply to a certificate that is issued by a certification authority (CA) that is populated in the NTAuth store and to any certificates that are part of the trust chain used to verify the NTAuth store certificate.

HKEY_Local_Machine\System\CurrentControlSet\Services\KDC\CRLTimeoutPeriod

This DWORD value lets you to specify the CRL time-out period to reduce false positives. The Key Distribution Center (KDC) passes this value to the certificate policy checking code. By default, the KDC specifies a time-out value of 90 seconds even if this registry value is not set.

HKEY_Local_Machine\System\CurrentControlSet\Control\Lsa\Kerberos\Parameters\CRLTimeoutPeriod

This DWORD value lets you to specify the CRL time-out period to reduce false positives. The Kerberos client passes this value to the certificate policy checking code. By default, the Kerberos client specifies a time-out value of 90 seconds even if this registry value is not set.

WORKAROUND

To work around this problem, disable the policy that requires a smart card to log on. To disable this policy, follow these steps:
  1. Click Start, click Run, type gpedit.msc, and then click OK.
  2. Under Local Computer Policy, expand Computer Configuration, expand Windows Settings, and then expand Security Settings.
  3. Expand Local Policies, and then click Security Options.
  4. In the right pane, double-click Interactive logon: Require smart card.
  5. Click Disabled, and then click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about PKI and CRL, see the "Checklist: Deploying smart cards for logging on to Windows" Help topic on the following Microsoft Web site: For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:7/24/2006
Keywords:kbQFE kbHotfixServer kbBug kbCertServices kbPPKey kbSmartCard kbWinServ2003preSP1fix kbfix kbprb KB887578 kbAudITPRO