FIX: You may receive the "OutOfMemoryException" error message when you perform a Site Deployment Import preview in Content Management Server 2002 (887574)



The information in this article applies to:

  • Microsoft Content Management Server 2002 SP1a
  • Microsoft Content Management Server 2002 SP1

SYMPTOMS

When you try to view an Import Preview report in Microsoft Content Management Server 2002, you may receive the following error message:
Exception of type System.OutOfMemoryException was thrown.
Additionally, when you try to perform the Site Deployment Import preview on the same Site Deployment Object (.sdo) file, you receive the same error message.

CAUSE

This problem occurs when you try to import a large .sdo file. When you perform the Site Deployment Import preview, Content Management Server 2002 tries to buffer the request. Therefore, an "OutOfMemoryException" exception is thrown for large .sdo files.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Content Management Server 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Content Management Server 2002 Service Pack 1a.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   15-Nov-2004  20:33  5.0.4531.0         64,336  Microsoft.contentmanagement.common.dll  

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Steps to reproduce the problem

  1. Click Start, click Programs, click Microsoft Content Management Server, and then click Site Manager.
  2. In the Site Manager dialog box, log on as a system administrator, and then click Start.
  3. On the File menu, click Package, and then click Import.
  4. In the Site Deployment Import dialog box, click Browse.
  5. In the Select SDO file for Import dialog box, click the large .sdo file, and then click Open.
  6. On the Reports menu, click Import Preview.

REFERENCES

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbContentMgtServ2002preSP2Fix kbfix kbBug kbprb KB887574 kbAudDeveloper kbAudITPRO