A user may log on successfully after a smart card certificate is revoked or after their user account is disabled in Windows XP (887535)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

A user may log on successfully to a computer when either of the following conditions is true even though their smart card certificate has been revoked or their user account has been disabled in Microsoft Windows XP:
  • If the smart card certificate of the user has been revoked and the user has tried unsuccessfully to log on online at least one time, the user may still be able to log on offline and have access to network resources by using the NET USE command.
  • If the account of the user has been disabled in the Active Directory directory service and the user has tried unsuccessfully to log on online at least one time, the user may successfully log on offline.

CAUSE

This problem may occur because the cached credentials for the user are still enabled.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

There are no prerequisites to install this hotfix.

Restart information

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix is not replaced by any later hotfix.

Registry information

You do not have to create or modify any registry keys to activate any hotfixes that this package contains.

Hotfix file information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   --------------------------------------------------------
   07-Oct-2004  23:04  5.1.2600.2524  294,912  Kerberos.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

REFERENCES

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbWinXPpreSP3fix kbWinXPsp3fix kbfix kbbug KB887535 kbAudITPRO