Users intermittently receive a "The network path was not found" error when they try to access a shared resource on a Windows 2000-based server cluster (887415)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server

SYMPTOMS

On a Microsoft Windows 2000-based server cluster, you may intermittently experience all the following symptoms:
  • When a user uses the UNC path to try to connect to a shared resource on the server cluster, that user receives the following error message:
    The network path was not found.
  • When a user tries to connect to the shared resource by specifying the IP address instead of the UNC path, that user receives the following error message:
    The filename, directory name, or volume label syntax is incorrect.
  • Users who are already connected to the shared resource do not experience any problems when they try to access files or folders on this shared resource.
  • If you restart the computer, the problem is temporarily resolved.
  • If you have the correct symbols installed, and if you debug the Memory.dmp file, the following information appears:

    0: kd> !THREAD 884538a0
    THREAD 884538a0  Cid 8.6e4  Teb: 00000000  Win32Thread: 00000000 WAIT: (Executive) 
    KernelMode Non-Alertable
        88275344  NotificationEvent
    IRP List:
        87fa2e48: (0006,0190) Flags: 00000830  Mdl: 00000000
    Impersonation token:  e29db7d0 (Level Impersonation)
    Owning Process 8908c3c0
    Wait Start TickCount    20523292      Elapsed Ticks: 218857
    Context Switch Count    14956
    UserTime                  0:00:00.0000
    KernelTime                0:00:06.0781
    Start Address srv!WorkerThread (0xbe8d72d4)
    Stack Init bea18000 Current bea17ab0 Base bea18000 Limit bea15000 Call 0
    Priority 10 BasePriority 9 PriorityDecrement 0 DecrementCount 0
    
    ChildEBP RetAddr  Args to Child
    bea17ac8 8042bfc7 00000103 00000000 87fa2e48 nt!KiSwapThread+0x1b1
    bea17af0 804abb4b 88275344 00000000 bea17b00 nt!KeWaitForSingleObject+0x1a3
    bea17c04 be8d2093 0029bff0 bea17c34 e22b6450 nt!NtSetInformationFile+0x5a7
    bea17c54 be8d56af 8869a448 bea17d50 0029bff0 srv!DoRename+0x22f
    bea17cf4 be8d39c2 00000000 e1eb71d0 00000010 srv!SrvMoveFile+0x215
    bea17d84 be8d73e9 00000000 00000000 00000000 srv!BlockingRename+0x1f0
    bea17da8 804554ce 8869a448 00000000 00000000 srv!WorkerThread+0x115
    bea17ddc 8046a9d2 be8d72d4 be8cdfe8 00000000 nt!PspSystemThreadStartup+0x54
    00000000 00000000 00000000 00000000 00000000 nt!KiThreadStartup+0x16
    
    0: kd> dt IRP 87fa2e48
       +0x000 Type             : 6
       +0x002 Size             : 0x190
       +0x004 MdlAddress       : (null)
       +0x008 Flags            : 0x830
       +0x00c AssociatedIrp    : __unnamed
       +0x010 ThreadListEntry  : _LIST_ENTRY [ 0x88453aac - 0x88453aac ]
       +0x018 IoStatus         : _IO_STATUS_BLOCK
       +0x020 RequestorMode    : 0 ''
       +0x021 PendingReturned  : 0 ''
       +0x022 StackCount       : 8 ''
       +0x023 CurrentLocation  : 10 ''
       +0x024 Cancel           : 0 ''
       +0x025 CancelIrql       : 0 ''
       +0x026 ApcEnvironment   : 0 ''
       +0x027 AllocationFlags  : 0xc ''
       +0x028 UserIosb         : 0xbea17c34
       +0x02c UserEvent        : (null)
       +0x030 Overlay          : __unnamed
       +0x038 CancelRoutine    : (null)
       +0x03c UserBuffer       : (null)
       +0x040 Tail             : __unnamed
    0: kd> dt IO_STATUS_BLOCK 87fa2e48+18
       +0x000 Status           : -1073741790
       +0x000 Pointer          : 0xc0000022
       +0x004 Information      : 4
    0: kd> !error c0000022
    

    Note Error code (NTSTATUS code) 0xc0000022 (decimal 3221225506) indicates an "access denied" condition. In this scenario, a process has requested access to an object, but the process has not been granted access rights to that object.

CAUSE

This issue may occur if you are running VERITAS StorageCentral 4.1, or if you are running Precise Software Solutions WQuinn/StorageCentral SRM 5.0 for Windows on the Windows 2000-based computer.

RESOLUTION

To resolve this issue, contact VERITAS to obtain an update for the StorageCentral program.

Note The VERITAS StorageCentral program was previously a product of Precise Software and was known as WQuinn StorageCentral.

For information about how to contact VERITAS, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and software vendor contact information, A-K

60781 Hardware and software vendor contact information, L-P

60782 Hardware and software vendor contact information, Q-Z

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:1/4/2006
Keywords:kb3rdparty kbtshoot KB887415 kbAudITPRO