Pop-up window closes unexpectedly during a download in Internet Explorer 6 (887301)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0, when used with:
    • Microsoft Windows XP Home Edition SP2
    • Microsoft Windows XP Professional SP2
    • Microsoft Windows Server 2003 SP1

SYMPTOMS

After you install Microsoft Windows XP Service Pack 2 (SP2) or you install Microsoft Windows Server 2003 Service Pack 1 (SP1), you may experience the following problem in Microsoft Internet Explorer 6.

You open a Web page that has a hidden iframe. Then you click a button that sets the source of the hidden iframe to an ASP page that initiates a file download with the Content-Disposition set to attachment. In the File Download dialog box, when you click any one of the following buttons, the file download is opened, saved, or canceled correctly:
  • Open
  • Save
  • Cancel
However, the window with the iframe that initiated the download closes. This window did not close before Windows XP SP2 or Windows Server 2003 SP1 was installed.

Additionally, you may experience this problem if you are using a frameset that has a simple link to a download URL from a page in the frameset.

This problem occurs only when the page that has the hidden iframe or the frameset was opened by using the window.open method.

CAUSE

Microsoft is researching this problem and will post more information in this article when the information becomes available.

WORKAROUND

To work around this problem, initiate the content with window.open instead of inside the iframe on the Web page. To do this, use the following sample script as an example.

Microsoft provides programming examples for illustration only, without warranty either expressed or implied, including, but not limited to, the implied warranties of merchantability or fitness for a particular purpose. This article assumes that you are familiar with the programming language that is being demonstrated and the tools that are used to create and debug procedures. Microsoft support professionals can help explain the functionality of a particular procedure, but they will not modify these examples to provide added functionality or construct procedures to meet your specific requirements. If you have limited programming experience, you may want to contact a Microsoft Certified Partner or the Microsoft fee-based consulting line at (800) 936-5200. For more information about Microsoft Certified Partners, visit the following Microsoft Web site:For additional information about the support options available from Microsoft, visit the following Microsoft Web site: You can use the following code to determine whether your computer is running Windows XP SP2.
<SCRIPT>
var bIsXP=false;
var bIsXPSP2=false;
window.onload=fnInit;

function fnInit()
{
   if(navigator.userAgent.indexOf("Windows NT 5.1")>-1)
   {
      bIsXP=true;
   }

   if(bIsXP==true)
   {
      if(navigator.userAgent.indexOf("SV1")>-1)
      {
        bIsXPSP2 = true;
      }
   }

   alert(bIsXPSP2);

   if (bIsXPSP2)
   {
      //do the special code, basically, redirect to the XPSP2 page
      window.location = "page_xpsp2.htm";
   }
}
</SCRIPT>

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:9/15/2006
Keywords:kbtshoot kbprb KB887301 kbAudEndUser