The Previous Versions tab for a file or for a folder in a DFS share is not displayed in Windows Server 2003 and in Windows XP (887189)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
  • Microsoft Windows XP Professional

SYMPTOMS

Assume the following scenario: You use a Terminal Services session on a Microsoft Windows Server 2003-based computer or on a Microsoft Windows XP-based computer to connect to a Distributed File System (DFS) share in a domain-based DFS root. Additionally, the following conditions are true:
  • The DFS root is hosted on a Windows Server 2003-based domain controller or on a Microsoft Windows 2000-based domain controller.
  • If the DFS root is hosted on a Windows Server 2003-based domain controller, the Shadow Copies of Shared Folders feature is not enabled on that domain controller.
  • The DFS share is a shared folder on a computer that is running Windows Server 2003. The Shadow Copies of Shared Folders feature is enabled on that server.
When you view the properties of a file or of a folder that is in the shared folder, the Previous Versions tab is not displayed in the FileNameOrFolderName Properties dialog box. You expect the Previous Versions tab to be present if the Shadow Copies of Shared Folders feature is enabled on the server.

CAUSE

When you view the properties of a file or of a folder, the Windows client computer checks to determine whether snapshots are available. The information about snapshots is cached on the client computer. If the Shadow Copies of Shared Folders feature is not enabled on the server that hosts the DFS root, the client detects that snapshots are not available. This information is cached on the client computer and is applied to all folders and subfolders under the DFS root, even though snapshots are available for the folders and for the subfolders.

RESOLUTION

Windows Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.Prerequisites
No prerequisites are required.
Restart requirement
You must restart your computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, 32-bit editions

Date         Time   Version       Size    File name
---------------------------------------------------
06-Jan-2005  02:06  6.0.3790.245  69,120  Twext.dll 

Windows Server 2003, 64-bit edition

Date         Time   Version        Size    File name  Platform
--------------------------------------------------------------
06-Jan-2005  02:02  6.0.3790.245  154,112  Twext.dll     IA-64
06-Jan-2005  02:06  6.0.3790.245   69,120  Wtwext.dll     x86

Windows XP

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.Prerequisites
No prerequisites are required.
Restart requirement
You must restart your computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows XP, 32-bit editions

Date         Time   Version        Size    File name  SP level
--------------------------------------------------------------
15-Dec-2004  18:50  6.0.3800.2580  45,056  Twext.dll    SP2   
15-Dec-2004  19:04  6.0.3800.1613  39,936  Twext.dll    SP1
Windows XP, 64-Bit Edition

Date         Time   Version         Size    File name  Platform
---------------------------------------------------------------
15-Dec-2004  18:59  6.0.3800.1613  130,560  Twext.dll    IA-64
15-Dec-2004  19:04  6.0.3800.1613   39,936  Wtwext.dll    x86

WORKAROUND

To work around this problem, enable the Shadow Copies of Shared Folders feature on the Windows Server 2003-based domain controller that hosts the DFS root. To do this, follow these steps:
  1. Click Start, right-click My Computer, and then click Manage.
  2. Expand System Tools if it is not already expanded.
  3. Right-click Shared Folders, point to All Tasks, and then click Configure Shadow Copies.
  4. Click the volume that hosts the DFS root, and then click Enable.
  5. If you are prompted to confirm the operation, click Yes.
  6. Click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the Volume Copy Shadow Service, visit the following Microsoft Web site: For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:6/20/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbWinServ2003preSP1fix KB887189 kbAudITPRO