You experience problems when you disconnect a single IEEE 1394 device from a computer that is running Windows XP SP2 (887170)



The information in this article applies to:

  • Microsoft Windows XP Home Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Professional Service Pack 2 (SP2)

SYMPTOMS

When you have a single Institute of Electrical and Electronics Engineers (IEEE) 1394 device connected to your Microsoft Windows XP Service Pack 2 (SP2)-based computer, you may experience problems when you disconnect the device. For example, you may receive an error message, or the computer may stop responding. The specific symptom may depend on the software that you use in conjunction with the IEEE 1394 device.

This problem does not occur if you have more than one IEEE 1394 device connected, and then you disconnect a device.

CAUSE

This problem occurs because the Windows XP SP2 IEEE 1394 stack does not send an IEEE 1394 bus reset notification to the IEEE 1394 virtual drivers.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size    File name
   ------------------------------------------------------
   19-Oct-2004  23:49  5.1.2600.2532  53,248  1394bus.sys

WORKAROUND

To work around this problem, restart your computer.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/2/2006
Keywords:kberrmsg kbWinXPsp3fix kbWinXPpreSP3fix kbfix kbbug kbQFE kbHotfixServer KB887170 kbAudEndUser