FIX: Windows Media Player may return an NS_E_INVALID_DATA error when playing Fast Cached content (887078)



The information in this article applies to:

  • Microsoft Windows Media Player 10
  • Microsoft Windows Media Player 9 Series for Windows 2000
  • Microsoft Windows Media Player 9 Series for Windows Server 2003
  • Microsoft Windows Media Player 9 Series for Windows XP
  • Microsoft Encarta Encyclopedia 2000 Concise Edition
  • Microsoft Encarta Encyclopedia 2000 Deluxe Edition

SYMPTOMS

When you play back content from a Microsoft Windows Media Player 10 server or from a Windows Media Player 9 Series server with Fast Cache enabled, a problem may occur. You may receive the following error message from the client:
0xC00D002F: Invalid or corrupt data was encountered.

CAUSE

If Windows Media Player receives a sample with a timestamp that increases more than five minutes when compared to the timestamp of the previous sample, you may receive the error message that is mentioned in the "Symptoms" section. Typically, audio streams and video streams send multiple samples per second. Therefore, a large increase in the time in the timestamp indicates some kind of error. However, with sparse streams, such as script streams, this is different. Typically, sparse streams do have a large increase in the time in the timestamp between samples.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next release that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Windows Media Player 9 Series for Microsoft Windows XP

The following file is available for download from the Microsoft Download Center:
DownloadDownload the WindowsXP-KB887078-v2-X86-ENU.exe package now.

Windows Media Player 9 Series for Microsoft Windows 2000 and Windows Server 2003

The following file is available for download from the Microsoft Download Center:
DownloadDownload the WindowsMedia9-KB887078-v2-x86-ENU.exe package now.

Windows Media Player 10

The following file is available for download from the Microsoft Download Center:
DownloadDownload the WindowsMedia10-KB887078-x86-ENU.exe package now.

For more information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to obtain Microsoft support files from online services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

The English version of this version has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Media Player 9 Series all operating systems

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   30-Sep-2004  14:39  9.0.0.3259      2,105,344  Wmvcore.dll

Windows Media Player 10

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   18-Oct-2004  18:38  10.0.0.3651     2,362,104  Wmvcore.dll

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

WORKAROUND

To work around this problem, you can disable the Fast Cache feature in the Windows Media Services (WMS) 9 Series. For additional information about the Fast Cache feature, see the WMS product documentation that is included with the product. To do this, click Help in Server Administrator.

Modification Type:MinorLast Reviewed:6/2/2006
Keywords:kbtshoot kbfix kbQFE kbHotfixServer KB887078 kbAudDeveloper