FIX: Network-attached storage-based system may stop responding when you access an NFS share under heavy conditions (886962)



The information in this article applies to:

  • Microsoft Windows Storage Server 2003
  • Microsoft Server Appliance Kit (SAK), version 2.01

SYMPTOMS

When you access network file system (NFS) shares under heavy I/O conditions in a Windows-based network-attached storage solution, the computer may stop responding (hang).

CAUSE

This problem occurs when one of the filter drivers in the Persistent Storage Manager (PSM) package unconditionally uses delayed worker threads to finish I/O requests to disks. Therefore, a deadlock condition may occur when there are many I/O access requests to an NFS share.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   13-Oct-2004  16:00  2.2.0.2282        202,072  Psman5.sys
   13-Oct-2004  16:00  2.2.0.2282         84,800  Psmlapi.dll      
   13-Oct-2004  16:00  2.2.0.2282         60,176  Ss.exe           

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

The NFS server process creates a delayed worker thread for each I/O request that it receives. When there are many access requests on an NFS share, and the maximum number of delayed worker threads is limited, the requests for a delayed worker thread from NFS are put in a pending state. In this state, the requests for delayed worker threads from other modules are also put in a pending state.

The psman5.sys driver in the PSM package is a file system filter driver that monitors I/O requests on files. When this problem occurs in a specific thread, the psman5.sys driver catches a non-cached I/O request from the file system driver. The psman5.sys driver then tries to create a delayed worker thread for this I/O request. This request for a delayed worker thread is put in a pending state. The thread is in a pending state because it is waiting for the I/O to finish. Additionally, the thread is holding a resource that many other delayed worker threads are waiting for.

The resulting condition is that the psman5.sys driver is waiting for one of the delayed worker threads to finish its work so that the driver can acquire one delayed worker thread. Additionally, the delayed worker threads are directly or indirectly waiting for the resource that is held by the very thread that psman5.sys is waiting in. Therefore, a deadlock condition occurs, and the system stops responding (hangs).

REFERENCES

For additional information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbBug kbfix kbprb KB886962 kbAudITPRO