The values in the Request.ClientCertificate object are not displayed correctly in IIS 6.0 (886810)



The information in this article applies to:

  • Microsoft Internet Information Services version 6.0

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you access and view the contents of a client certificate by using the Request object's ClientCertificate collection (Request.ClientCertificate) in Microsoft Internet Information Services (IIS) 6.0, the values in the Request.ClientCertificate object are not displayed correctly. Additionally, the values in the Request.ClientCertificate object may not be the same as the values that are displayed in IIS 5.0.

CAUSE

This problem occurs because of a change in the output format of the Request object's ClientCertificate collection in IIS 6.0 when compared to the output format in IIS 5.0. In IIS 5.0, binary large object (BLOB) arrays are converted to basic strings (BSTR), and then sent to the client. In IIS 6.0, binary large object arrays are sent to the client as binary large objects. If binary large objects are not read correctly by the client, the values in the Request.ClientCertificate object may not be displayed correctly.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows Server 2003
Date         Time   Version            Size    File name
--------------------------------------------------------------
19-Oct-2004  22:39  6.0.3790.224      380,416  Asp.dll 
Windows Server 2003 64-bit edition
Date         Time   Version            Size    File name  Platform
-----------------------------------------------------------------------
19-Oct-2004  10:09  6.0.3790.224      983,040  Asp.dll    IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

After you install the hotfix, create the DisableCertificateBlobAsArray registry entry. To do this, follow these steps:

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate and then right-click the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ASP\Parameters

    Note If the Parameters key is not found, you must create it.
  3. Click New, and then click DWORD Value.
  4. Type DisableCertificateBlobAsArray, and then press ENTER.
  5. Right-click DisableCertificateBlobAsArray, and then click Modify.
  6. Type 1 in the Value data box, and then click OK.

    Note If you assign a value of 1 to the DisableCertificateBlobAsArray registry entry, the same behavior occurs in IIS 6.0 and in IIS 5.0. If you assign a null value (0) to the DisableCertificateBlobAsArray registry entry, IIS 6.0 works as if the hotfix is not applied, and the problem may occur again.
  7. Close Registry Editor.
  8. Restart the World Wide Publishing service. To do this, follow these steps:
    1. Click Start, point to Programs, point to Administrative Tools, and then click Services.
    2. Right-click World Wide Web Publishing Service, and then click Restart.

Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbtshoot kbfix kbBug kbWinServ2003preSP1fix kbHotfixServer kbQFE KB886810 kbAudITPRO