Some users do not receive a program that is advertised to a user group in Systems Management Server 2003 (886797)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

If you advertise a program to a user group, some members of the user group do not receive the advertisement.

CAUSE

This problem occurs because the user is a member of more than 175 user groups. The Policy Agent component on an Advanced Client computer requests user policy assignments from the management point. The Policy Agent component sends a list of the user groups where the logged-on user is a member. The management point returns the advertisements that are assigned to those user groups.

If one of the following conditions are true, the Advanced Client receives only those advertisements that are assigned to the first 175 user groups in the list:
  • The list of user groups from the Advanced Client is more than 8 KB.
  • The list of user groups from the Advanced Client is approximately 175 user groups.
The Advanced Client does not receive any advertisements that are assigned to user groups that are later than the first 175 user groups in the list.

The Policy Manager component on the management point receives all the user groups that are reported by the Advanced Client. However, the Microsoft SQL MP_GetUserAndUserGroupPolicyAssignments stored procedure can only process a user group list that is less than 8 KB.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Systems Management Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

885643 How To obtain the latest Systems Management Server 2003 service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Systems Management Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.Prerequisites You must have SMS 2003 SP1 to apply this hotfix.Restart requirement You do not have to restart your computer after you apply this hotfix.Hotfix replacement information This hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Size    File name
   --------------------------------------
   10-Jan-2005  11:12  18,096  Update.sql

Hotfix installation information

To apply this hotfix, run a Microsoft SQL script on your Microsoft Systems Management Server (SMS) 2003 database server. To do this, follow these steps:
  1. Copy the self-extracting hotfix file Sms2003-sp1-kb886797-x86-enu.exe to your SMS 2003 database server.
  2. Run Sms2003-sp1-kb886797-x86-enu.exe to start the hotfix Setup wizard.
  3. Accept the license agreement by clicking I Agree. Click Next, and then click Finish.
  4. Click Start, point to All Programs, point to Microsoft SQL Server, and then click Query Analyzer.
  5. Connect to your SQL server.
  6. On the Query menu, click Change Database.
  7. Click the name of your SMS database, and then click OK.
  8. On the File menu, click Open.
  9. Open the SMS\Logs\KB886797 folder, click Update.sql, and then click Open.
  10. On the Query menu, click Execute.
Note If you have replicated the SMS database to another Microsoft SQL server, you must follow these steps on the Microsoft SQL server that contains the replicated database. This hotfix does not automatically update replicated SMS 2003 databases.

SMS 2003 International Client Pack 1 (ICP1)

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Systems Management Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.Prerequisites You must have SMS 2003 ICP1 to apply this hotfix.Restart requirement You do not have to restart your computer after you apply this hotfix.Hotfix replacement information This hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Size    File name
   --------------------------------------
   10-Jan-2005  11:12  18,096  Update.sql
Hotfix installation informationTo apply this hotfix, run a Microsoft SQL script on your SMS 2003 database server. To do this, follow these steps:
  1. Copy the self-extracting hotfix file Sms2003-sp1-kb886797-x86-icp1.exe to your SMS 2003 database server.
  2. Run Sms2003-sp1-kb886797-x86-enu.exe to start the hotfix Setup wizard.
  3. Accept the license agreement by clicking I Agree. Click Next, and then click Finish.
  4. Click Start, point to All Programs, point to Microsoft SQL Server, and then click Query Analyzer.
  5. Connect to your SQL server.
  6. On the Query menu, click Change Database.
  7. Click the name of your SMS database, and then click OK.
  8. On the File menu, click Open.
  9. Open the SMS\Logs\KB886797 folder, click Update.sql, and then click Open.
  10. On the Query menu, click Execute.
Note If you have replicated the SMS database to another Microsoft SQL server, you must follow these steps on the Microsoft SQL server that contains the replicated database. This hotfix does not automatically update replicated SMS 2003 databases.

SMS 2003 International Client Pack 2 (ICP2)

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Systems Management Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.Prerequisites You must have SMS 2003 ICP2 to apply this hotfix.Restart requirement You do not have to restart your computer after you apply this hotfix.Hotfix replacement information This hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Size    File name
   --------------------------------------
   10-Jan-2005  11:12  18,096  Update.sql

Hotfix installation information

To apply this hotfix, you must run a Microsoft SQL script on your SMS 2003 database server. To do this, follow these steps:
  1. Copy the self-extracting hotfix file Sms2003-sp1-kb886797-x86-icp2.exe to your SMS 2003 database server.
  2. Run Sms2003-sp1-kb886797-x86-enu.exe to start the hotfix Setup wizard.
  3. Accept the license agreement by clicking I Agree. Click Next, and then click Finish.
  4. Click Start, point to All Programs, point to Microsoft SQL Server, and then click Query Analyzer.
  5. Connect to your SQL server.
  6. On the Query menu, click Change Database.
  7. Click the name of your SMS database, and then click OK.
  8. On the File menu, click Open.
  9. Open the SMS\Logs\KB886797 folder, click Update.sql, and then click Open.
  10. On the Query menu, click Execute.
Note If you have replicated the SMS database to another Microsoft SQL server, you must follow these steps on the Microsoft SQL server that contains the replicated database. This hotfix does not automatically update replicated SMS 2003 databases.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Systems Management Server 2003 Service Pack 2.

MORE INFORMATION

For additional information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbSMSSecurity kbSMSPackage kbSMSMP kbSMSDistribution kbSMSDeploy kbSMSClients kbSMS2003bug kbDatabase kbAdvertisement kbClient kbUser kbPerformance kbSecurity kbSoftwareDist kbfix KB886797 kbAudITPRO