Subsequent nodes cannot join a cluster, and events 1070 and 1009 are logged with Windows Server 2003 (886717)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems

SYMPTOMS

The first node can successfully join a cluster. However, subsequent nodes cannot join the cluster, and the following events are recorded in the System log:

Event ID: 1070
Event Source: ClusSvc
Description:
The node failed to begin the process of joining the server cluster. The error code was 1726.Event ID: 1009
Event Source: ClusSvc
Description:
Cluster service could not join an existing server cluster and could not form a new server cluster. Cluster service has terminated.

CAUSE

This problem occurs when there are many resources on a cluster. Cluster resources are maintained in the cluster hive. When a node joins a cluster, the complete cluster hive is saved to the hard disk. If the cluster hive is large, this process may take longer than the node join time-out period.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, Enterprise Edition

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   13-Oct-2004  19:27  5.2.3790.222      804,864  Clussvc.exe      

Windows Server 2003, Enterprise Edition for Itanium-based Editions

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   13-Oct-2004  20:35  5.2.3790.222    1,938,944  Clussvc.exe   

WORKAROUND

To work around this problem, remove some of the resources to reduce the size of the cluster hive so that it is under 10 megabytes. To determine the size of the cluster hive, follow these steps on the cluster node:
  1. Click Start, click Run, type Explorer, and then click OK.
  2. Locate the Clusdb file in the %systemroot%\Cluster folder, and then examine the Size column.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/2/2006
Keywords:kbwinservnetwork kbnetwork kbBug kbfix kbWinServ2003preSP1fix kbQFE kbHotfixServer KB886717 kbAudITPRO kbAudDeveloper