Some programs stop unexpectedly when you start Java Web Start on a computer that is running a French, German or Italian version of Microsoft Windows NT 4.0 (886703)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Server, Enterprise Edition 4.0
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Advanced Server 4.0

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

SYMPTOMS

On a computer that is running a French, German, or Italian version of Microsoft Windows NT 4.0, when you start the Java Web Start program (Javaw.exe) while you run Java-based programs in Microsoft Internet Explorer, some programs stop unexpectedly.

Note This problem occurs after you install the security update that is described in Microsoft Security Bulletin MS04-011. For additional information about Microsoft Security Bulletin MS04-011, click the following article number to view the article in the Microsoft Knowledge Base:

835732 MS04-011: Security Update for Microsoft Windows

Java Web Start is a product of Sun Microsystems.

CAUSE

The problem occurs because programs that use the Javaw.exe process stop unexpectedly when the Msvcrt.dll file is relocated in memory. This situation may occur when the Gdi32.dll file occupies the same memory location as the Msvcrt.dll file.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To install this hotfix, you must have Microsoft Windows NT 4.0 Service Pack 6a installed on your computer.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows NT Server 4.0
   Date         Time   Version             Size  File name
   --------------------------------------------------------
   15-Oct-2004  13:38  4.0.1381.7270    206,096  Gdi32.dll
   15-Oct-2004  13:38  4.0.1381.7263     40,720  Mf3216.dll
   15-Oct-2004  13:38  4.0.1381.7273    326,928  User32.dll
   17-Sep-2004  20:56  4.0.1381.7255  1,255,472  Win32k.sys
   15-Oct-2004  13:38  4.0.1381.7260    174,864  Winsrv.dll
Windows NT Workstation 4.0
   Date         Time   Version            Size    File name
   --------------------------------------------------------
   15-Oct-2004  13:38  4.0.1381.7270    206,096  Gdi32.dll
   15-Oct-2004  13:38  4.0.1381.7263     40,720  Mf3216.dll
   15-Oct-2004  13:38  4.0.1381.7273    326,928  User32.dll
   17-Sep-2004  20:56  4.0.1381.7255  1,255,472  Win32k.sys
   15-Oct-2004  13:38  4.0.1381.7260    174,864  Winsrv.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MajorLast Reviewed:5/15/2006
Keywords:kbQFE kbfix kbbug kbHotfixServer KB886703 kbAudITPRO